Closed Bug 1265238 Opened 5 years ago Closed 3 years ago

Yahoo videos don't play with 'media.autoplay.enabled=false'

Categories

(Core :: Audio/Video: Playback, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1382574
Tracking Status
platform-rel --- -
firefox48 --- affected

People

(Reporter: jimm, Unassigned)

References

()

Details

(Whiteboard: [platform-rel-Yahoo!])

Spin off from bug 1264091, I'm not able to get these yahoo videos to play. Tested with tracking protection disabled, and in e10s and non-e10s mode.


STR:
1) Load any of the videos on this yahoo site
2) Disable tracking protection, reload
3) Wait for the ad to finish playing

result: endless spinning load video indicator

Videos play in Chrome and IE.


console spew:

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://bats.video.yahoo.com/p?t=0.15980312642306793&_V=V&s=1197784175&V_sec=pb&evt=v_ncomp&ccode=&sec=&cpos=&type=vod%20short&dur=0&dur_d=0&view=100%25&watchpct=0&stall_t=0&buff_info=%7B%22seg%22%3A%5B%7B%22seq_num%22%3A0%2C%22ib%22%3A495%2C%22ob%22%3A%220.00%22%2C%22num_buf%22%3A0%2C%22buf_dur%22%3A0%2C%22req_t%22%3A0%2C%22fb_dl_t%22%3A18%2C%22req_dl_t%22%3A1177%2C%22drop_f%22%3A0%2C%22avg_fr%22%3A%220.00%22%2C%22vis%22%3Afalse%7D%5D%7D&buf_dur=0&ui_pop_active=false&pl_type=false&pl_uuid=&vpa_td=dc-firefox~p-vod_hlspre~s-defaultExpn~css-static&vid=a5bfb783-94f7-32cc-b501-7d796ea572f2&pstaid=a5bfb783-94f7-32cc-b501-7d796ea572f2&prt=html5-hls&lms_id=a0Vd0000005TvwmEAC&vs=a6256hgi&psz=1001x654&cdn=atlas&st=hls&sp=https&bit=0&pls=1257496998&vlng=209&site=music&lang=en-us&intl=us&lbl=none&synd=&pver=7.3.0.1460766741&expn=&expt=&expb=901&loc=onProp&auto=true&cont=1&bckt=prod&snd=um&test=901&_w=https%3A%2F%2Fwww.yahoo.com%2Fmusic%2Fsoul-sensation-jones-a-name-to-remember-215508304.html&vsid=1197784175&_R=&pltype=nextgen-desktop&cached_vs=&man=&class=&smpl=0&env=p. (Reason: CORS header 'Access-Control-Allow-Origin' missing).(unknown)
Failed to execute 'postMessage' on 'DOMWindow': The target origin provided ('https://www.yahoo.com') does not match the recipient window's origin ('https://s.yimg.com').r-sf.html
Failed to execute 'postMessage' on 'DOMWindow': The target origin provided ('https://www.yahoo.com') does not match the recipient window's origin ('https://s.yimg.com').r-sf-flx.html
Failed to execute 'postMessage' on 'DOMWindow': The target origin provided ('https://www.yahoo.com') does not match the recipient window's origin ('https://s.yimg.com').r-sf.html
DARLA notice: 437g-r-min.js:3
DARLA notice: 426g-r-min.js:3
DARLA notice: 405g-r-min.js:3
DARLA notice: 405g-r-min.js:3
DARLA notice: 405g-r-min.js:3
Content Security Policy: Ignoring "'unsafe-inline'" within script-src or style-src: nonce-source or hash-source specified(unknown)
'mozHidden' and 'mozVisibilityState' are deprecated.  Please use the unprefixed 'hidden' and 'visibilityState' instead.vce_st.js:2:9990
Prefixed Fullscreen API is deprecated. Please use unprefixed API for fullscreen. For more help https://developer.mozilla.org/en-US/docs/Web/API/Fullscreen_APIcombo:885
An unbalanced tree was written using document.write() causing data from the network to be reparsed. For more information https://developer.mozilla.org/en/Optimizing_Your_Pages_for_Speculative_Parsings_0RdM6XiNLH_1005123613.html:2
Error: Permission denied to access property "toString"moatad.js:188:229
Error: Permission denied to access property "toString"(unknown)
Prefixed Fullscreen API is deprecated. Please use unprefixed API for fullscreen. For more help https://developer.mozilla.org/en-US/docs/Web/API/Fullscreen_APIvideoplayer-min.js:12:21425
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More]/
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More]/
'mozHidden' and 'mozVisibilityState' are deprecated.  Please use the unprefixed 'hidden' and 'visibilityState' instead.soul-sensation-jones-a-name-to-remember-215508304.html:23:1065
how do you enable html5 video?

loads with flash here (tested on mac with nightly)
Flags: needinfo?(jmathies)
I just load the page. The ad is a flash ad, but the video that gets stuck at the loading throbber is an html5 video with context menu controls.
Flags: needinfo?(jmathies)
I had media.autoplay.enabled pref set to false. The "play" button on these videos fails to work in this case.
Summary: Yahoo html5 videos don't play → Yahoo videos don't play with 'media.autoplay.enabled=false'
Gerald - is this a dup of something in your queue?
Flags: needinfo?(gsquelart)
(In reply to Jim Mathies [:jimm] from comment #3)
> I had media.autoplay.enabled pref set to false. The "play" button on these
> videos fails to work in this case.

This is a site issue which is shared by a good number of sites. We need to find a solution that works better than media.autoplay.enabled=false
platform-rel: --- → ?
Whiteboard: [platform-rel-Yahoo!]
Mass change P2 -> P3
Priority: P2 → P3
platform-rel: ? → +
Similar issue on twitch.tv.

This similar bug https://bugzilla.mozilla.org/show_bug.cgi?id=1292894 was closed as invalid, however the issue is present on main twitch.tv site which just switched to HTML5 by default.

Steps to reproduce (using Windows 10 64bit, Firefox 49.0.1):
1) Create new firefox profile (firefox -P)
2) Go to https://www.twitch.tv/directory/all and pick a channel, cannot give you an actual url since live channels come and go.
3) Observe that HTML5 player is started and video plays
4) Open a 2nd firefox tab and: about:config -> media.autoplay.enabled=false
5) Reload 1st tab with twitch; observe that video won't play, even clicking the play icon
6) In the 2nd firefox tab and: set media.autoplay.enabled=true
7) Reload 1st tab with twitch; observe that video plays automatically
platform-rel: + → -
similar failure on https://vimeo.com/196940171 with a clean profile of 51.0b10 with media.autoplay.enabled set to false.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1382574
Flags: needinfo?(gsquelart)
You need to log in before you can comment on or make changes to this bug.