Closed Bug 1265633 Opened 6 years ago Closed 6 years ago

Assertion failure: nsDisplayItem::TYPE_TEXT == i->GetType(), at nsDisplayList.cpp:518

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1264949

People

(Reporter: cbook, Unassigned)

References

()

Details

(Keywords: assertion)

Assertion failure: nsDisplayItem::TYPE_TEXT == i->GetType(), at c:/Users/mozilla/debug-builds/mozilla-central/layout/base/nsDisplayList.cpp:518

found via bughunter and reproduced on todays m-c tip 

Steps to reproduce:
-> Load http://giphy.com/create/gifcaption
--> Assertion failure: nsDisplayItem::TYPE_TEXT == i->GetType(), at c:/Users/mozilla/debug-builds/mozilla-central/layout/base/nsDisplayList.cpp:518


Assertion failure: nsDisplayItem::TYPE_TEXT == i->GetType(), at c:/Users/mozilla/debug-builds/mozilla-central/layout/base/nsDisplayList.cpp:518
#01: nsDisplayBackgroundImage::PaintInternal[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x4a72133]
#02: nsDisplayBackgroundImage::Paint[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x4a6fb85]
#03: mozilla::FrameLayerBuilder::PaintItems[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x497e971]
#04: mozilla::FrameLayerBuilder::DrawPaintedLayer[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x496cacd]
#05: mozilla::layers::BasicPaintedLayer::PaintThebes[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x1e3569f]
#06: mozilla::layers::BasicLayerManager::PaintSelfOrChildren[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x1e3521a]
#07: mozilla::layers::BasicLayerManager::PaintLayer[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x1e3466b]
#08: mozilla::layers::BasicLayerManager::PaintSelfOrChildren[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x1e352ee]
#09: mozilla::layers::BasicLayerManager::PaintLayer[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x1e3466b]
#10: mozilla::layers::BasicLayerManager::EndTransactionInternal[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x1e2df81]
#11: mozilla::layers::BasicLayerManager::EndTransaction[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x1e2d9e2]
#12: mozilla::gfx::BaseIntRegion<mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits>,mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits>,mozilla::gfx::IntPointTyped<mozilla::gfx::UnknownUnits>,mozilla::gfx::IntMarginTyped<mozilla::gfx::UnknownUnits> >:[c:\Users\mozilla\debug-builds\mozilla
entral\firefox-debug\dist\bin\xul.dll +0x497e380]
#13: mozilla::FrameLayerBuilder::PaintItems[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x497e8df]
#14: mozilla::FrameLayerBuilder::DrawPaintedLayer[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x496cacd]
#15: mozilla::layers::ClientPaintedLayer::PaintThebes[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x1e35d4e]
#16: mozilla::layers::ClientPaintedLayer::RenderLayerWithReadback[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x1e3a1ca]
#17: mozilla::layers::ClientContainerLayer::RenderLayer[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x1e390c3]
#18: mozilla::layers::ClientLayer::RenderLayerWithReadback[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x1e39fd4]
#19: mozilla::layers::ClientContainerLayer::RenderLayer[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x1e390c3]
#20: mozilla::layers::ClientLayer::RenderLayerWithReadback[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x1e39fd4]
#21: mozilla::layers::ClientContainerLayer::RenderLayer[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x1e390c3]
#22: mozilla::layers::ClientLayerManager::EndTransactionInternal[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x1e2e4eb]
#23: mozilla::layers::ClientLayerManager::EndTransaction[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x1e2da45]
#24: nsDisplayList::PaintRoot[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x4a7381a]
#25: nsLayoutUtils::PaintFrame[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x4a7165a]
#26: PresShell::Paint[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x4a6f5dc]
#27: nsViewManager::ProcessPendingUpdatesPaint[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x44f8224]
#28: nsViewManager::ProcessPendingUpdatesForView[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x44f7faf]
#29: nsViewManager::ProcessPendingUpdates[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x44f7d92]
#30: nsRefreshDriver::Tick[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x4946d82]
#31: mozilla::RefreshDriverTimer::TickDriver[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x49475a1]
#32: mozilla::RefreshDriverTimer::TickRefreshDrivers[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x4947a5d]
#33: mozilla::RefreshDriverTimer::Tick[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x4945ca4]
#34: mozilla::VsyncRefreshDriverTimer::RunRefreshDrivers[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x4944839]
#35: mozilla::VsyncRefreshDriverTimer::RefreshDriverVsyncObserver::TickRefreshDriver[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x494792c]
#36: ??$applyImpl@VRefreshDriverVsyncObserver@VsyncRefreshDriverTimer@mozilla@@P8123@AEXVTimeStamp@3@@ZU?$StoreCopyPassByValue@VTimeStamp@mozilla@@@@$$Z$0A@@?$nsRunnableMethodArguments@VTimeStamp@mozilla@@@@SAXPAVRefreshDriverVsyncObserver@VsyncRefreshDriverTi[c:\Users\mozilla\debug-builds\mozilla
entral\firefox-debug\dist\bin\xul.dll +0x4939d4a]
#37: nsRunnableMethodArguments<mozilla::TimeStamp>::apply<mozilla::VsyncRefreshDriverTimer::RefreshDriverVsyncObserver,void (__thiscall mozilla::VsyncRefreshDriverTimer::RefreshDriverVsyncObserver::*)(mozilla::TimeStamp)>[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll
0x4939c9f]
#38: nsRunnableMethodImpl<void (__thiscall mozilla::VsyncRefreshDriverTimer::RefreshDriverVsyncObserver::*)(mozilla::TimeStamp),1,mozilla::TimeStamp>::Run[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x4944320]
#39: nsThread::ProcessNextEvent[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x751835]
#40: NS_ProcessNextEvent[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x7bbf52]
#41: mozilla::ipc::MessagePump::Run[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0xfbdf49]
#42: MessageLoop::RunInternal[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0xf4a72d]
#43: MessageLoop::RunHandler[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0xf4a6a2]
#44: MessageLoop::Run[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0xf4a29d]
#45: nsBaseAppShell::Run[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x4543660]
#46: nsAppShell::Run[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x45efa63]
#47: nsAppStartup::Run[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x567504f]
#48: XREMain::XRE_mainRun[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x571d1ea]
#49: XREMain::XRE_main[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x5719e67]
#50: XRE_main[c:\Users\mozilla\debug-builds\mozilla-central\firefox-debug\dist\bin\xul.dll +0x571faaa]
#51: do_main (c:\users\mozilla\debug-builds\mozilla-central\browser\app\nsbrowserapp.cpp:220)
#52: NS_internal_main (c:\users\mozilla\debug-builds\mozilla-central\browser\app\nsbrowserapp.cpp:360)
#53: wmain (c:\users\mozilla\debug-builds\mozilla-central\toolkit\xre\nswindowswmain.cpp:135)
#54: __scrt_common_main_seh (f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:264)
#55: BaseThreadInitThunk[C:\Windows\system32\kernel32.dll +0x4ef1c]
#56: RtlInitializeExceptionChain[C:\Windows\SYSTEM32\ntdll.dll +0x63b53]
This looks like bug 1264949, for which a patch has just landed on inbound. I'll leave it open until we check whether that resolves it...
Depends on: 1264949
Yes, this abort can be fixed by bug 1264949. 
But I do find a bug while visiting this page.
The Number glyphs(with background-clip:text) are not put on the correct place because of transform: translate(-50%, -50%) skewX(-10deg)
File bug 1265715 for comment #2
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1264949
You need to log in before you can comment on or make changes to this bug.