Closed Bug 1265666 Opened 4 years ago Closed 11 months ago

Implement missing SVG 2 values of vector-effect property

Categories

(Core :: SVG, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1318208

People

(Reporter: sebo, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug, )

Details

(Keywords: dev-doc-needed)

Currently the 'vector-effect' property only supports the values 'none' and 'non-scaling-stroke' while the SVG 2 spec. allows more values and repetition. The exact syntax is:

  none | [ non-scaling-stroke | non-scaling-size | non-rotation | fixed-position ]+ [ viewport | screen ]?

Sebastian
Duplicate of this bug: 1303567
Component: SVG → CSS Parsing and Computation
The main part of this support seems to be SVG side. Adding a property is trivial in CSS, but implement the effect is not.
Component: CSS Parsing and Computation → SVG
Sounds reasonable. Thanks Xidorn!

Sebastian
Summary: Implement missing SVG 2 values vector-effect property → Implement missing SVG 2 values of vector-effect property
Depends on: 1318208
Blocks: svg2
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1318208
You need to log in before you can comment on or make changes to this bug.