Links within a document are broken in reader mode

VERIFIED FIXED in Firefox 48

Status

()

defect
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: kats, Unassigned)

Tracking

48 Branch
mozilla48
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox48 verified)

Details

Go to a page like http://www.gutenberg.org/files/3300/3300-h/3300-h.htm (Wealth of Nations, by Adam Smith, online HTML version). Note that it has a Table of Contents section near the top with links to different parts of the document.

Now enter reader mode on this document, and try to use those links. You get redirected to a directory listing page instead of navigating within the document. This happens both in desktop Firefox (I checked Nightly 48 on OS X) and Android (checked Aurora 47 on a Nexus 4).
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #0)
> Go to a page like http://www.gutenberg.org/files/3300/3300-h/3300-h.htm
> (Wealth of Nations, by Adam Smith, online HTML version). Note that it has a
> Table of Contents section near the top with links to different parts of the
> document.
> 
> Now enter reader mode on this document, and try to use those links. You get
> redirected to a directory listing page instead of navigating within the
> document. This happens both in desktop Firefox (I checked Nightly 48 on OS
> X) and Android (checked Aurora 47 on a Nexus 4).

It looks like Readability is stripping the file name from the url:

http://www.gutenberg.org/files/3300/3300-h/3300-h.htm#link2H_INTR
http://www.gutenberg.org/files/3300/3300-h/#link2H_INTR

There is logic to fix relative URIs, but I'm not sure how that would result in this bug:
https://github.com/mozilla/readability/blob/master/Readability.js#L208

We should file an issue in the readability repo, and we should add a test for this.

Comment 2

3 years ago
I have a vague recollection that I fixed this, and I am less sure that I updated the in-tree version since then... I'll try to check later today.
Flags: needinfo?(gijskruitbosch+bugs)

Comment 3

3 years ago
https://github.com/gijsk/readability/commit/dffa760c04824431cbfdf04f4a8eb4034b905891 fixed this, but the in-tree version is on an older rev. I'll try to land something later today.

Comment 4

3 years ago
It'd be so nice if we had a way to easily run relevant front-end tests and platforms on try. But we don't, so this will have to do:

remote:   https://treeherder.mozilla.org/#/jobs?repo=try&revision=a3486bc7c8ca

Assuming this is green-ish tomorrow morning, I'll land then.

Comment 5

3 years ago
(In reply to :Gijs Kruitbosch from comment #4)
> It'd be so nice if we had a way to easily run relevant front-end tests and
> platforms on try. But we don't, so this will have to do:
> 
> remote:  
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=a3486bc7c8ca
> 
> Assuming this is green-ish tomorrow morning, I'll land then.

remote:   https://hg.mozilla.org/integration/fx-team/rev/387167675e15
Flags: needinfo?(gijskruitbosch+bugs)

Comment 6

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/387167675e15
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
So that fixed getting redirected, but now clicking on the link pops me out of reader mode. Is that intentional? My expectation was that clicking on the same-document link in reader mode would stay in reader mode.
QA Whiteboard: [good first verify]

Comment 8

3 years ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #7)
> So that fixed getting redirected, but now clicking on the link pops me out
> of reader mode. Is that intentional? My expectation was that clicking on the
> same-document link in reader mode would stay in reader mode.

No, it isn't. I'm a bit miffed that this comment got lost in my bugmail - we should file a new bug on this, though I wouldn't be entirely surprised if this is somehow a result of bug 1280584.

Updated

3 years ago
Blocks: 1280888
I have reproduced this bug with Nightly 48.0a1 (2016-04-19) on Windows 7, 64 Bit!

The Bug's fix is verified on Latest Beta 48.0b2.

Build ID 	20160630123429
User Agent 	Mozilla/5.0 (Windows NT 6.1; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
QA Whiteboard: [good first verify] → [good first verify][bugday-20160706]

Comment 10

3 years ago
Was able to reproduce but with Nightly 48.0a1 (2016-03-31) on Mac Yosemite 10.10.2. When you click on any of the links in Reader Mode you get taken to Index page.

In Firefox 48.0b7 on Mac Yosemite 10.10.2 when I click on any of the links in Reader Mode I do get taken to the correct spot in the book, but I also get kicked out of reader mode.

Comment 11

3 years ago
We should deal with the fallout in bug 1280888. Meanwhile, marking this as verified because the readability change is correct and backing it out would only make things worse, not better.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.