Closed Bug 1266052 Opened 4 years ago Closed 4 years ago

crash in nsMsgGroupView::GetCellProperties

Categories

(MailNews Core :: Backend, defect, critical)

Unspecified
Windows NT
defect
Not set
critical

Tracking

(thunderbird46 wontfix, thunderbird47 fixed, thunderbird48 fixed, thunderbird_esr4546+ fixed)

RESOLVED FIXED
Thunderbird 48.0
Tracking Status
thunderbird46 --- wontfix
thunderbird47 --- fixed
thunderbird48 --- fixed
thunderbird_esr45 46+ fixed

People

(Reporter: wsmwk, Unassigned)

Details

(Keywords: regression, regressionwindow-wanted, topcrash-thunderbird)

Crash Data

Attachments

(1 file)

#18 crash for 45.0 

This would appear to be a regression. First appears in crash-stats with build 20150920030322 bp-bebf18c5-c7b2-4d45-bf58-a58342160125.
 0 	xul.dll	nsMsgGroupView::GetCellProperties(int, nsITreeColumn*, nsAString_internal&)	c:/builds/moz2_slave/tb-c-cen-w64-ntly-000000000000/build/mailnews/base/src/nsMsgGroupView.cpp:752
1 	xul.dll	nsTreeBodyFrame::PaintCell(int, nsTreeColumn*, nsRect const&, nsPresContext*, nsRenderingContext&, nsRect const&, int&, nsPoint)	layout/xul/tree/nsTreeBodyFrame.cpp
2 	xul.dll	nsTreeBodyFrame::PaintRow(int, nsRect const&, nsPresContext*, nsRenderingContext&, nsRect const&, nsPoint)	layout/xul/tree/nsTreeBodyFrame.cpp
3 	xul.dll	nsTreeBodyFrame::PaintTreeBody(nsRenderingContext&, nsRect const&, nsPoint)	layout/xul/tree/nsTreeBodyFrame.cpp
4 	xul.dll	nsDisplayTreeBody::Paint(nsDisplayListBuilder*, nsRenderingContext*)	layout/xul/tree/nsTreeBodyFrame.cpp
5 	xul.dll	mozilla::FrameLayerBuilder::PaintItems(nsTArray<mozilla::FrameLayerBuilder::ClippedDisplayItem>&, mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const&, gfxContext*, nsRenderingContext*, nsDisplayListBuilder*, nsPresContext*, mozilla::gfx::IntPointTyped<mozilla::gfx::UnknownUnits> const&, float, float, int)	layout/base/FrameLayerBuilder.cpp 

One user of 45.0a2 (probably @oracle) bp-c95c5da3-d019-47c9-8ed1-2f5fc2160120 writes "doing a quick search... ".  Another crash of his/hers is bp-a95a8d90-e6c6-43e8-9585-64e472160120
this might fix it.
Attachment #8743272 - Flags: review?(rkent)
Comment on attachment 8743272 [details] [diff] [review]
groupThread.patch

Review of attachment 8743272 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.
Attachment #8743272 - Flags: review?(rkent) → review+
Keywords: checkin-needed
Comment on attachment 8743272 [details] [diff] [review]
groupThread.patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on c-c, etc.): 
Risk to taking this patch (and alternatives if risky):
Attachment #8743272 - Flags: approval-comm-esr45?
(In reply to alta88 from comment #3)
> Comment on attachment 8743272 [details] [diff] [review]
> groupThread.patch
> 
> [Approval Request Comment]

no risk patch for a crasher.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 48.0
Comment on attachment 8743272 [details] [diff] [review]
groupThread.patch

http://hg.mozilla.org/releases/comm-esr45/rev/b1331bff1348
Attachment #8743272 - Flags: approval-comm-esr45? → approval-comm-esr45+
Comment on attachment 8743272 [details] [diff] [review]
groupThread.patch

[Triage Comment]
This should be landed on Aurora TB 47 for the next 47 beta.
Attachment #8743272 - Flags: approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.