Remove unnecessary compiler version checks for gcc <= 4.8.0 in mfbt

RESOLVED FIXED in Firefox 48

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: cpeterson, Assigned: cpeterson)

Tracking

unspecified
mozilla48
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox47 wontfix, firefox48 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
Created attachment 8743661 [details] [diff] [review]
remove-gcc-version-check.patch

Now that we require gcc >= 4.8.5, we can remove these compiler version checks for older gcc versions.

If bug 1243233 is reverted, then Linux mulet builds' gcc version requirement will drop from 4.9.3 to 4.7.3 and this bug's Endian.h change would need to be reverted.
Attachment #8743661 - Flags: review?(nfroyd)
Comment on attachment 8743661 [details] [diff] [review]
remove-gcc-version-check.patch

Review of attachment 8743661 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for cleaning this up.
Attachment #8743661 - Flags: review?(nfroyd) → review+

Comment 3

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/5b1c09821da1
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox48: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
You need to log in before you can comment on or make changes to this bug.