Closed Bug 1266407 Opened 7 years ago Closed 7 years ago

-webkit-text-fill-color should not apply to the glyph border

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: ehsan.akhgari, Unassigned)

References

()

Details

This bug is visible on Nightly on <http://www.bloomberg.com/news/features/2016-04-21/the-2-trillion-project-to-get-saudi-arabia-s-economy-off-oil>.  We paint the entire text of the title as white, making it invisible, but Chrome only used -webkit-text-fill-color to fill in the text, and the border around the glyphs remains visible, painted using the color specified in the CSS color property.
I see they also have -webkit-text-stroke: 0.09375rem #FA1E64; set on .feature-article .lede-headline, which is being implemented in Bug 1248708. Once we have that, this should look the same as in Chrome I think.

(see also https://bugzilla.mozilla.org/show_bug.cgi?id=1248644#c9)
I think we can probably dupe this against Bug 1248644, since they're both about Bloomberg.com headlines not behaving as expected (and both require having -webkit-text-fill-color *and* -webkit-text-stroke).
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
I think maybe I closed this too fast. Let's set Bug 1248708 as a blocker and verify against this URL once that lands to be sure.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Via bug 1248708 for -webkit-text-stroke, I can confirm that this is FIXED in latest Nightly since webkit-text-fill-color respects webkit-text-stroke now.

Combined with bug 1269971, the page can be rendered in a more compatible way in comparison w/ Chrome. See bug 1248644 for details.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Depends on: 1248708
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.