Closed Bug 1266574 Opened 6 years ago Closed 5 years ago

Remove Expiring Buypass Class 2 CA 1 root certificate

Categories

(NSS :: CA Certificates Code, task)

task
Not set
normal

Tracking

(firefox48 affected)

RESOLVED FIXED
Tracking Status
firefox48 --- affected

People

(Reporter: kwilson, Unassigned)

References

Details

(Whiteboard: Removed in NSS 3.28.1, Firefox 51)

Please remove the following root certificate from NSS:

CN = Buypass Class 2 CA 1
O = Buypass AS-983163327
C = NO
SHA1 Fingerprint: A0:A1:AB:90:C9:FC:84:7B:3B:12:61:E8:97:7D:5F:D3:22:61:D3:CC
SHA256 Fingerprint: 0F:4E:9C:DD:26:4B:02:55:50:D1:70:80:63:40:21:4F:E9:44:34:C9:B0:2F:69:7E:C7:10:FC:5F:EA:FB:5E:38
Trust Bits enabled: Websites
Expires on: October 13, 2016

This root cert is not enabled for EV treatment.

This root cert is not included in the audit statement dated March 23, 2016, because during the audit period no certificates were issued that chained up to this root. However, there are still valid certificates chaining up to this root, so the CA has asked that it not be removed until October, 2016.
Depends on: 1290999
Depends on: 1296697
No longer depends on: 1290999
The test build for this change is here:
https://archive.mozilla.org/pub/firefox/try-builds/kaie@kuix.de-0ff968e3d09e43aa1186a83d9df1b0159adf61e0/

I have tested and confirmed that this Buypass Class 2 CA 1 root cert has been removed.

The CA is welcome to test (though not required for root removals), as described here:
https://wiki.mozilla.org/CA:How_to_apply#Testing_Inclusion
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: Removed in NSS 3.28.1, Firefox 51
You need to log in before you can comment on or make changes to this bug.