Some Web Audio FFT results unexpectedly need to be scaled by two

RESOLVED DUPLICATE of bug 1424906

Status

()

P4
normal
RESOLVED DUPLICATE of bug 1424906
2 years ago
8 months ago

People

(Reporter: dminor, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
There's a note in FFTBlock.h about results being scaled by two for compatibility between libav and kissfft/openmax [1].

I ended up having to add a scaling factor of two to make the "unscaled" version of the inverse FFT routine in Bug 1158741 work.

Now when adding a test case for the unnormalized PeriodicWave in Bug 1265405 I ended up having to add another scaling factor of two to make the test results work out.

This seems wrong, but it's quite possible I'm missing something here.

[1] https://dxr.mozilla.org/mozilla-central/source/dom/media/webaudio/FFTBlock.h#113
Mass change P3->P4 to align with new Mozilla triage process.
Priority: P3 → P4
(Reporter)

Comment 2

8 months ago
It appears that problem is actually that PeriodicWave unexpectedly needs to be scaled by 0.5.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1424906
You need to log in before you can comment on or make changes to this bug.