Closed Bug 1266791 Opened 4 years ago Closed 4 years ago

Couldn't load XPCOM

Categories

(Firefox Build System :: General, defect)

48 Branch
x86
Windows XP
defect
Not set

Tracking

(firefox47 unaffected, firefox48+ fixed, firefox49+ fixed)

RESOLVED FIXED
mozilla49
Tracking Status
firefox47 --- unaffected
firefox48 + fixed
firefox49 + fixed

People

(Reporter: silence, Assigned: froydnj)

References

Details

(Keywords: regression)

Attachments

(1 file)

After update to version from 21 april, Firefox install update and not run. Show always info: Couldn't load XPCOM. I use portable version few month i had never problems after updates. Check few different version from march and aprli and after update to build from 21 aprli Firefox not run. It is possible that the cause is Windows XP or old processor or something. Don't know, but before 21 april Nightly 48 working good.
I have this issue too after the update yesterday from Earlybird 47.0a2 to 48.0a2 on a machine running XP SP3 with a AMD processor non SSE2;

Is that the reason ?
(47.0a2 versions are working fine)

I will try with the Dev Ed 48.0a2 when the update from 47.0a2 will be enabled tomorrow)
I also use the CPU AMD non SSE2 supported. I checked many versions Aurora and Nightly
Results: 
Aurora 47 all versions working. Latest working version is: 
https://archive.mozilla.org/pub/firefox/nightly/2016/04/2016-04-25-00-40-18-mozilla-aurora/firefox-47.0a2.en-US.win32.zip

Aurora 48 first and all next version starting from: https://archive.mozilla.org/pub/firefox/nightly/2016/04/2016-04-26-00-41-07-mozilla-aurora/firefox-48.0a2.en-US.win32.zip not working (show Couldn't load XPCOM.)

Nightly 47 all working, Nightly 48 latest official working is: https://archive.mozilla.org/pub/firefox/nightly/2016/04/2016-04-19-03-03-12-mozilla-central/firefox-48.0a1.en-US.win32.zip

Nightly 48 first not working is: https://archive.mozilla.org/pub/firefox/nightly/2016/04/2016-04-21-03-03-02-mozilla-central/firefox-48.0a1.en-US.win32.zip (show Couldn't load XPCOM.)

Nightly 49 all version not working

Need to check what the key difference is between: 
https://archive.mozilla.org/pub/firefox/nightly/2016/04/2016-04-19-03-03-12-mozilla-central/firefox-48.0a1.en-US.win32.zip 
and 
https://archive.mozilla.org/pub/firefox/nightly/2016/04/2016-04-21-03-03-02-mozilla-central/firefox-48.0a1.en-US.win32.zip

My system is XP and AMD Athlon processor. Someone can help me, and check this bug?
I just update Aurora from 470.a2 to 48.0a2 and same issue : Couldn't load XPCOM 

This happen on a PC with a CPU AMD Sempron 3000+ running XP SP3

On an other machine with a CPU Intel P4 and XP SP3 , all run well
My is Athlon XP 2400+. Probably in AMD processors is problem. Any of thousands Mozilla supporters not used this processors, check and fix bug? What will happen if Aurora 48 version change to beta 47 and bug still will not be fixed?
As I can see the hardware requirements for Firefox 48.0a2 :
https://www.mozilla.org/en-US/firefox/48.0a2/system-requirements/
and don't open on my machine

it is the same as 45.0 that work well on my machine:
https://www.mozilla.org/en-US/firefox/45.0/system-requirements/

Beta 47.0 Beta 1 too work well ....
hi, could you narrow down the regression range with the tool from https://mozilla.github.io/mozregression/install.html ?
Flags: needinfo?(silence)
I try the mozregression-gui (it's long with a bad network :( ):
the last good is :
app_name: firefox
build_date: 2016-04-25 17:08:33.204000
build_file: C:/Program Files/mozregression-gui\8551b253f406--mozilla-aurora--firefox-47.0a2.en-US.win32.zip
build_type: inbound
build_url: https://queue.taskcluster.net/v1/task/dBmcfpVbS9K5XSLyUdZTBA/runs/0/artifacts/public%2Fbuild%2Ffirefox-47.0a2.en-US.win32.zip
changeset: 8551b253f4061db31e4be7829c2f70c2610caf42
pushlog_url: https://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=8551b253f4061db31e4be7829c2f70c2610caf42&tochange=0d6a91c76a9eddf2219caf028dea130f2d683ec2
repo_name: mozilla-aurora
repo_url: https://hg.mozilla.org/releases/mozilla-aurora
task_id: dBmcfpVbS9K5XSLyUdZTBA

The first bad is :
app_name: firefox
build_date: 2016-04-25 20:10:39.318000
build_file: C:/Program Files/mozregression-gui\0d6a91c76a9e--mozilla-aurora--firefox-48.0a2.en-US.win32.zip
build_type: inbound
build_url: https://queue.taskcluster.net/v1/task/GiLbJ1aqToWo4J2RJnOSuw/runs/0/artifacts/public%2Fbuild%2Ffirefox-48.0a2.en-US.win32.zip
changeset: 0d6a91c76a9eddf2219caf028dea130f2d683ec2
pushlog_url: https://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=98da47b4d83c576ce17d189942d2655df5a36dc1&tochange=0d6a91c76a9eddf2219caf028dea130f2d683ec2
repo_name: mozilla-aurora
repo_url: https://hg.mozilla.org/releases/mozilla-aurora
task_id: GiLbJ1aqToWo4J2RJnOSuw
sorry, you seemed to have the test with mozilla aurora which doesn't yield useful results - please try again with nightly builds ("mozilla-central").
So I redo the mozregression with mozilla-central (it take ~1h and a half ....)

the result :
- mozilla-central last good : 
app_name: firefox
build_date: 2016-04-19
build_file: C:/Program Files/mozregression-gui\2016-04-19--mozilla-central--firefox-48.0a1.en-US.win32.zip
build_type: nightly
build_url: https://archive.mozilla.org/pub/firefox/nightly/2016/04/2016-04-19-03-03-12-mozilla-central/firefox-48.0a1.en-US.win32.zip
changeset: ae7413abfa4d3954a6a4ce7c1613a7100f367f9a
pushlog_url: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=564b225d553547fe4aa9a1039278f695c9507db9&tochange=2045bc8c9e90a7ca0b8c6447ddecd812a71b29e1
repo_name: mozilla-central
repo_url: https://hg.mozilla.org/mozilla-central

first bad :
app_name: firefox
build_date: 2016-04-20
build_file: C:/Program Files/mozregression-gui\2016-04-20--mozilla-central--firefox-48.0a1.en-US.win32.zip
build_type: nightly
build_url: https://archive.mozilla.org/pub/firefox/nightly/2016/04/2016-04-20-03-02-13-mozilla-central/firefox-48.0a1.en-US.win32.zip
changeset: f05a1242fb29023bd7ebc492897ed3d6907733c7
pushlog_url: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ae7413abfa4d3954a6a4ce7c1613a7100f367f9a&tochange=f05a1242fb29023bd7ebc492897ed3d6907733c7
repo_name: mozilla-central
repo_url: https://hg.mozilla.org/mozilla-central

-mozilla-central build good :
app_name: firefox
build_date: 2016-04-20 11:39:53.606000
build_file: C:/Program Files/mozregression-gui\973dfa158221--mozilla-central--firefox-48.0a1.en-US.win32.zip
build_type: inbound
build_url: https://queue.taskcluster.net/v1/task/S4FFUP_8RKSnFZgr1W1HSg/runs/0/artifacts/public%2Fbuild%2Ffirefox-48.0a1.en-US.win32.zip
changeset: 973dfa15822126c39ea2d98d34ac16643b040243
pushlog_url: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=973dfa15822126c39ea2d98d34ac16643b040243&tochange=f05a1242fb29023bd7ebc492897ed3d6907733c7
repo_name: mozilla-central
repo_url: https://hg.mozilla.org/mozilla-central
task_id: S4FFUP_8RKSnFZgr1W1HSg

mozilla-inbound :

bad : 
app_name: firefox
build_date: 2016-04-19 15:44:26.234000
build_file: C:/Program Files/mozregression-gui\94a006ee5874--mozilla-inbound--firefox-48.0a1.en-US.win32.zip
build_type: inbound
build_url: https://queue.taskcluster.net/v1/task/EZZALsZ_Sfu_5ixlBseogA/runs/0/artifacts/public%2Fbuild%2Ffirefox-48.0a1.en-US.win32.zip
changeset: 94a006ee587456d17575d27dd6a5f56c2dcdfbde
pushlog_url: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d0376a3bc28621dbd95730c7ea12ccc8e8bc267f&tochange=94a006ee587456d17575d27dd6a5f56c2dcdfbde
repo_name: mozilla-inbound
repo_url: https://hg.mozilla.org/integration/mozilla-inbound
task_id: EZZALsZ_Sfu_5ixlBseogA

good :
app_name: firefox
build_date: 2016-04-19 11:45:00.089000
build_file: C:/Program Files/mozregression-gui\53376d36d3cf--mozilla-inbound--firefox-48.0a1.en-US.win32.zip
build_type: inbound
build_url: https://queue.taskcluster.net/v1/task/fgcU-XFuQYS9qI3pGqkjHg/runs/0/artifacts/public%2Fbuild%2Ffirefox-48.0a1.en-US.win32.zip
changeset: 53376d36d3cf6b740e48cd0c10fca34b32b013db
pushlog_url: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=53376d36d3cf6b740e48cd0c10fca34b32b013db&tochange=94a006ee587456d17575d27dd6a5f56c2dcdfbde
repo_name: mozilla-inbound
repo_url: https://hg.mozilla.org/integration/mozilla-inbound
task_id: fgcU-XFuQYS9qI3pGqkjHg

bad:
app_name: firefox
build_date: 2016-04-19 14:42:55.102000
build_file: C:/Program Files/mozregression-gui\7df73cfe3c2f--mozilla-inbound--firefox-48.0a1.en-US.win32.zip
build_type: inbound
build_url: https://queue.taskcluster.net/v1/task/bWAE5AAHR6m8ec3zw8R49Q/runs/0/artifacts/public%2Fbuild%2Ffirefox-48.0a1.en-US.win32.zip
changeset: 7df73cfe3c2f558242b806c6ae021dd363efebc5
pushlog_url: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=53376d36d3cf6b740e48cd0c10fca34b32b013db&tochange=7df73cfe3c2f558242b806c6ae021dd363efebc5
repo_name: mozilla-inbound
repo_url: https://hg.mozilla.org/integration/mozilla-inbound
task_id: bWAE5AAHR6m8ec3zw8R49Q

good:
app_name: firefox
build_date: 2016-04-19 14:48:53.962000
build_file: C:/Program Files/mozregression-gui\2f3a6b7cd4b3--mozilla-inbound--firefox-48.0a1.en-US.win32.zip
build_type: inbound
build_url: https://queue.taskcluster.net/v1/task/fq0rC1dnRjKn5OMEgL9vIw/runs/0/artifacts/public%2Fbuild%2Ffirefox-48.0a1.en-US.win32.zip
changeset: 2f3a6b7cd4b3e4a70be8b8849d4a9d0a11fe5100
pushlog_url: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2f3a6b7cd4b3e4a70be8b8849d4a9d0a11fe5100&tochange=7df73cfe3c2f558242b806c6ae021dd363efebc5
repo_name: mozilla-inbound
repo_url: https://hg.mozilla.org/integration/mozilla-inbound
task_id: fq0rC1dnRjKn5OMEgL9vIw

bad:
app_name: firefox
build_date: 2016-04-19 14:56:13.377000
build_file: C:/Program Files/mozregression-gui\68b14d04ea4e--mozilla-inbound--firefox-48.0a1.en-US.win32.zip
build_type: inbound
build_url: https://queue.taskcluster.net/v1/task/eMlh9y3ATjqiRzWzi8rVKA/runs/0/artifacts/public%2Fbuild%2Ffirefox-48.0a1.en-US.win32.zip
changeset: 68b14d04ea4e78be6e905a739df95e74cd1f97fd
pushlog_url: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2f3a6b7cd4b3e4a70be8b8849d4a9d0a11fe5100&tochange=68b14d04ea4e78be6e905a739df95e74cd1f97fd
repo_name: mozilla-inbound
repo_url: https://hg.mozilla.org/integration/mozilla-inbound
task_id: eMlh9y3ATjqiRzWzi8rVKA

good :
app_name: firefox
build_date: 2016-04-19 14:42:01.576000
build_file: C:/Program Files/mozregression-gui\894e3c1ce799--mozilla-inbound--firefox-48.0a1.en-US.win32.zip
build_type: inbound
build_url: https://queue.taskcluster.net/v1/task/bEbg9AOXRw-ELlwqGmcWkA/runs/0/artifacts/public%2Fbuild%2Ffirefox-48.0a1.en-US.win32.zip
changeset: 894e3c1ce7998d21cb193bdf66817ebd794c11e8
pushlog_url: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=894e3c1ce7998d21cb193bdf66817ebd794c11e8&tochange=68b14d04ea4e78be6e905a739df95e74cd1f97fd
repo_name: mozilla-inbound
repo_url: https://hg.mozilla.org/integration/mozilla-inbound
task_id: bEbg9AOXRw-ELlwqGmcWkA
[Tracking Requested - why for this release]:
this seems to be a serious issue, as firefox can no longer be opened on older hardware.
Blocks: 1265399
Flags: needinfo?(silence)
Keywords: regression
I checked between 19 and 20 april versions:

Four last working versions:

app_name: firefox
build_date: 2016-04-19 11:45:00.089000
build_file: D:\Documents and Settings\jukaru\.mozilla\mozregression\persist\53376d36d3cf--mozilla-inbound--firefox-48.0a1.en-US.win32.zip
build_type: inbound
build_url: https://queue.taskcluster.net/v1/task/fgcU-XFuQYS9qI3pGqkjHg/runs/0/artifacts/public%2Fbuild%2Ffirefox-48.0a1.en-US.win32.zip
changeset: 53376d36d3cf6b740e48cd0c10fca34b32b013db
pushlog_url: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=53376d36d3cf6b740e48cd0c10fca34b32b013db&tochange=94a006ee587456d17575d27dd6a5f56c2dcdfbde
repo_name: mozilla-inbound
repo_url: https://hg.mozilla.org/integration/mozilla-inbound
task_id: fgcU-XFuQYS9qI3pGqkjHg

app_name: firefox
build_date: 2016-04-19 14:42:01.576000
build_file: D:\Documents and Settings\jukaru\.mozilla\mozregression\persist\894e3c1ce799--mozilla-inbound--firefox-48.0a1.en-US.win32.zip
build_type: inbound
build_url: https://queue.taskcluster.net/v1/task/bEbg9AOXRw-ELlwqGmcWkA/runs/0/artifacts/public%2Fbuild%2Ffirefox-48.0a1.en-US.win32.zip
changeset: 894e3c1ce7998d21cb193bdf66817ebd794c11e8
pushlog_url: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=894e3c1ce7998d21cb193bdf66817ebd794c11e8&tochange=68b14d04ea4e78be6e905a739df95e74cd1f97fd
repo_name: mozilla-inbound
repo_url: https://hg.mozilla.org/integration/mozilla-inbound
task_id: bEbg9AOXRw-ELlwqGmcWkA

app_name: firefox
build_date: 2016-04-19 14:48:53.962000
build_file: D:\Documents and Settings\jukaru\.mozilla\mozregression\persist\2f3a6b7cd4b3--mozilla-inbound--firefox-48.0a1.en-US.win32.zip
build_type: inbound
build_url: https://queue.taskcluster.net/v1/task/fq0rC1dnRjKn5OMEgL9vIw/runs/0/artifacts/public%2Fbuild%2Ffirefox-48.0a1.en-US.win32.zip
changeset: 2f3a6b7cd4b3e4a70be8b8849d4a9d0a11fe5100
pushlog_url: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2f3a6b7cd4b3e4a70be8b8849d4a9d0a11fe5100&tochange=7df73cfe3c2f558242b806c6ae021dd363efebc5
repo_name: mozilla-inbound
repo_url: https://hg.mozilla.org/integration/mozilla-inbound
task_id: fq0rC1dnRjKn5OMEgL9vIw

app_name: firefox
build_date: 2016-04-20 11:39:53.606000
build_file: D:\Documents and Settings\jukaru\.mozilla\mozregression\persist\973dfa158221--mozilla-central--firefox-48.0a1.en-US.win32.zip
build_type: inbound
build_url: https://queue.taskcluster.net/v1/task/S4FFUP_8RKSnFZgr1W1HSg/runs/0/artifacts/public%2Fbuild%2Ffirefox-48.0a1.en-US.win32.zip
changeset: 973dfa15822126c39ea2d98d34ac16643b040243
pushlog_url: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=973dfa15822126c39ea2d98d34ac16643b040243&tochange=f05a1242fb29023bd7ebc492897ed3d6907733c7
repo_name: mozilla-central
repo_url: https://hg.mozilla.org/mozilla-central
task_id: S4FFUP_8RKSnFZgr1W1HSg


Three first not working:

app_name: firefox
build_date: 2016-04-19 14:42:55.102000
build_file: D:\Documents and Settings\jukaru\.mozilla\mozregression\persist\7df73cfe3c2f--mozilla-inbound--firefox-48.0a1.en-US.win32.zip
build_type: inbound
build_url: https://queue.taskcluster.net/v1/task/bWAE5AAHR6m8ec3zw8R49Q/runs/0/artifacts/public%2Fbuild%2Ffirefox-48.0a1.en-US.win32.zip
changeset: 7df73cfe3c2f558242b806c6ae021dd363efebc5
pushlog_url: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=53376d36d3cf6b740e48cd0c10fca34b32b013db&tochange=7df73cfe3c2f558242b806c6ae021dd363efebc5
repo_name: mozilla-inbound
repo_url: https://hg.mozilla.org/integration/mozilla-inbound
task_id: bWAE5AAHR6m8ec3zw8R49Q

app_name: firefox
build_date: 2016-04-19 14:56:13.377000
build_file: D:\Documents and Settings\jukaru\.mozilla\mozregression\persist\68b14d04ea4e--mozilla-inbound--firefox-48.0a1.en-US.win32.zip
build_type: inbound
build_url: https://queue.taskcluster.net/v1/task/eMlh9y3ATjqiRzWzi8rVKA/runs/0/artifacts/public%2Fbuild%2Ffirefox-48.0a1.en-US.win32.zip
changeset: 68b14d04ea4e78be6e905a739df95e74cd1f97fd
pushlog_url: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2f3a6b7cd4b3e4a70be8b8849d4a9d0a11fe5100&tochange=68b14d04ea4e78be6e905a739df95e74cd1f97fd
repo_name: mozilla-inbound
repo_url: https://hg.mozilla.org/integration/mozilla-inbound
task_id: eMlh9y3ATjqiRzWzi8rVKA

app_name: firefox
build_date: 2016-04-19 15:44:26.234000
build_file: D:\Documents and Settings\jukaru\.mozilla\mozregression\persist\94a006ee5874--mozilla-inbound--firefox-48.0a1.en-US.win32.zip
build_type: inbound
build_url: https://queue.taskcluster.net/v1/task/EZZALsZ_Sfu_5ixlBseogA/runs/0/artifacts/public%2Fbuild%2Ffirefox-48.0a1.en-US.win32.zip
changeset: 94a006ee587456d17575d27dd6a5f56c2dcdfbde
pushlog_url: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d0376a3bc28621dbd95730c7ea12ccc8e8bc267f&tochange=94a006ee587456d17575d27dd6a5f56c2dcdfbde
repo_name: mozilla-inbound
repo_url: https://hg.mozilla.org/integration/mozilla-inbound
task_id: EZZALsZ_Sfu_5ixlBseogA


Interestnig is why working: 
build_date: 2016-04-20 11:39:53.606000

and why not woking earlier:
build_date: 2016-04-19 14:42:55.102000
build_date: 2016-04-19 15:44:26.234000
build_date: 2016-04-19 14:56:13.377000

Log view error:
2016-04-30T23:28:14: DEBUG : This is a merge from mozilla-inbound
2016-04-30T23:28:14: DEBUG : Using url: https://hg.mozilla.org/integration/mozilla-inbound/json-pushes?changeset=02e86612b3798e5f3cc6a1cec2f55246096f8c9f
2016-04-30T23:28:14: DEBUG : Using url: https://hg.mozilla.org/integration/mozilla-inbound/json-pushes?fromchange=02e86612b3798e5f3cc6a1cec2f55246096f8c9f&tochange=34f5a7144be34c3f48ebfeb4cbe3bd38419c0c7c
2016-04-30T23:28:15: DEBUG : Using url: https://hg.mozilla.org/integration/mozilla-inbound/json-pushes?startID=75309&endID=75382
2016-04-30T23:28:15: INFO : ************* Switching to mozilla-inbound
2016-04-30T23:28:15: DEBUG : End merge handling
2016-04-30T23:28:15: DEBUG : Using url: https://hg.mozilla.org/integration/mozilla-inbound/json-pushes?changeset=cb65ec85049efa44b18e2e8d06af26768c3bfb94
2016-04-30T23:28:15: DEBUG : Using url: https://hg.mozilla.org/integration/mozilla-inbound/json-pushes?fromchange=cb65ec85049efa44b18e2e8d06af26768c3bfb94&tochange=34f5a7144be34c3f48ebfeb4cbe3bd38419c0c7c
2016-04-30T23:28:16: DEBUG : using taskcluster route 'gecko.v2.mozilla-inbound.revision.d0376a3bc28621dbd95730c7ea12ccc8e8bc267f.firefox.win32-opt'
2016-04-30T23:28:16: DEBUG : using taskcluster route 'gecko.v2.mozilla-inbound.revision.34f5a7144be34c3f48ebfeb4cbe3bd38419c0c7c.firefox.win32-opt'
2016-04-30T23:28:19: DEBUG : using taskcluster route 'gecko.v2.mozilla-inbound.revision.94a006ee587456d17575d27dd6a5f56c2dcdfbde.firefox.win32-opt'
2016-04-30T23:28:22: INFO : Running mozilla-inbound build built on 2016-04-19 15:44:26.234000, revision 94a006ee
2016-04-30T23:28:22: DEBUG : using taskcluster route 'gecko.v2.mozilla-inbound.revision.27b5119d82e01dded303cd795021483480ecd2e4.firefox.win32-opt'
2016-04-30T23:28:25: DEBUG : using taskcluster route 'gecko.v2.mozilla-inbound.revision.53376d36d3cf6b740e48cd0c10fca34b32b013db.firefox.win32-opt'
2016-04-30T23:28:30: INFO : Launching d:\docume~1\useran~1.000\ustawi~1\temp\tmpbyd8e2\firefox\firefox.exe
2016-04-30T23:28:30: INFO : application_buildid: 20160419074638
2016-04-30T23:28:30: INFO : application_changeset: 94a006ee587456d17575d27dd6a5f56c2dcdfbde
2016-04-30T23:28:30: INFO : application_display_name: Nightly
2016-04-30T23:28:30: INFO : application_id: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
2016-04-30T23:28:30: INFO : application_name: Firefox
2016-04-30T23:28:30: INFO : application_remotingname: firefox
2016-04-30T23:28:30: INFO : application_repository: https://hg.mozilla.org/integration/mozilla-inbound
2016-04-30T23:28:30: INFO : application_vendor: Mozilla
2016-04-30T23:28:30: INFO : application_version: 48.0a1
2016-04-30T23:28:30: INFO : platform_buildid: 20160419074638
2016-04-30T23:28:30: INFO : platform_changeset: 94a006ee587456d17575d27dd6a5f56c2dcdfbde
2016-04-30T23:28:30: INFO : platform_repository: https://hg.mozilla.org/integration/mozilla-inbound
2016-04-30T23:28:30: INFO : platform_version: 48.0a1
2016-04-30T23:29:15: WARNING : Process exited with code 255
2016-04-30T23:29:17: INFO : Narrowed inbound regression window from [d0376a3b, 34f5a714] (73 revisions) to [d0376a3b, 94a006ee] (37 revisions) (~5 steps left)
2016-04-30T23:29:17: INFO : Running mozilla-inbound build built on 2016-04-19 11:45:00.089000, revision 53376d36
2016-04-30T23:29:17: DEBUG : using taskcluster route 'gecko.v2.mozilla-inbound.revision.7df73cfe3c2f558242b806c6ae021dd363efebc5.firefox.win32-opt'
2016-04-30T23:29:20: DEBUG : using taskcluster route 'gecko.v2.mozilla-inbound.revision.d5d46a4ad2be4af1b0d32886f3d492c1292a21ce.firefox.win32-opt'
2016-04-30T23:29:25: INFO : Launching d:\docume~1\useran~1.000\ustawi~1\temp\tmp3epnwm\firefox\firefox.exe
2016-04-30T23:29:25: INFO : application_buildid: 20160419030844
2016-04-30T23:29:25: INFO : application_changeset: 53376d36d3cf6b740e48cd0c10fca34b32b013db
2016-04-30T23:29:25: INFO : application_display_name: Nightly
2016-04-30T23:29:25: INFO : application_id: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
2016-04-30T23:29:25: INFO : application_name: Firefox
2016-04-30T23:29:25: INFO : application_remotingname: firefox
2016-04-30T23:29:25: INFO : application_repository: https://hg.mozilla.org/integration/mozilla-inbound
2016-04-30T23:29:25: INFO : application_vendor: Mozilla
2016-04-30T23:29:25: INFO : application_version: 48.0a1
2016-04-30T23:29:25: INFO : platform_buildid: 20160419030844
2016-04-30T23:29:25: INFO : platform_changeset: 53376d36d3cf6b740e48cd0c10fca34b32b013db
2016-04-30T23:29:25: INFO : platform_repository: https://hg.mozilla.org/integration/mozilla-inbound
2016-04-30T23:29:25: INFO : platform_version: 48.0a1
2016-04-30T23:30:00: INFO : Narrowed inbound regression window from [d0376a3b, 94a006ee] (37 revisions) to [53376d36, 94a006ee] (19 revisions) (~4 steps left)
2016-04-30T23:30:00: INFO : Running mozilla-inbound build built on 2016-04-19 14:42:55.102000, revision 7df73cfe
2016-04-30T23:30:00: DEBUG : using taskcluster route 'gecko.v2.mozilla-inbound.revision.3732da92e8fccb4cc5dc7cdb615877c07e4dcbb9.firefox.win32-opt'
2016-04-30T23:30:02: WARNING : Skipping build 3732da92e8fc: Unable to find build info using the taskcluster route 'gecko.v2.mozilla-inbound.revision.3732da92e8fccb4cc5dc7cdb615877c07e4dcbb9.firefox.win32-opt'
2016-04-30T23:30:02: DEBUG : using taskcluster route 'gecko.v2.mozilla-inbound.revision.051663050bad3fd03cb3878e8e3d666a2ed4db8b.firefox.win32-opt'
2016-04-30T23:30:05: DEBUG : using taskcluster route 'gecko.v2.mozilla-inbound.revision.2f3a6b7cd4b3e4a70be8b8849d4a9d0a11fe5100.firefox.win32-opt'
2016-04-30T23:30:08: INFO : Launching d:\docume~1\useran~1.000\ustawi~1\temp\tmppw1okd\firefox\firefox.exe
2016-04-30T23:30:08: INFO : application_buildid: 20160419055250
2016-04-30T23:30:08: INFO : application_changeset: 7df73cfe3c2f558242b806c6ae021dd363efebc5
2016-04-30T23:30:08: INFO : application_display_name: Nightly
2016-04-30T23:30:08: INFO : application_id: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
2016-04-30T23:30:08: INFO : application_name: Firefox
2016-04-30T23:30:08: INFO : application_remotingname: firefox
2016-04-30T23:30:08: INFO : application_repository: https://hg.mozilla.org/integration/mozilla-inbound
2016-04-30T23:30:08: INFO : application_vendor: Mozilla
2016-04-30T23:30:08: INFO : application_version: 48.0a1
2016-04-30T23:30:08: INFO : platform_buildid: 20160419055250
2016-04-30T23:30:08: INFO : platform_changeset: 7df73cfe3c2f558242b806c6ae021dd363efebc5
2016-04-30T23:30:08: INFO : platform_repository: https://hg.mozilla.org/integration/mozilla-inbound
2016-04-30T23:30:08: INFO : platform_version: 48.0a1
2016-04-30T23:30:15: WARNING : Process exited with code 255
2016-04-30T23:30:17: INFO : Narrowed inbound regression window from [53376d36, 94a006ee] (18 revisions) to [53376d36, 7df73cfe] (10 revisions) (~3 steps left)
2016-04-30T23:30:17: INFO : Running mozilla-inbound build built on 2016-04-19 14:48:53.962000, revision 2f3a6b7c
2016-04-30T23:30:17: DEBUG : using taskcluster route 'gecko.v2.mozilla-inbound.revision.68b14d04ea4e78be6e905a739df95e74cd1f97fd.firefox.win32-opt'
2016-04-30T23:30:20: DEBUG : using taskcluster route 'gecko.v2.mozilla-inbound.revision.979bd96a0deea8f2dd7f5d341dce7e5dc46d11f2.firefox.win32-opt'
2016-04-30T23:30:25: INFO : Launching d:\docume~1\useran~1.000\ustawi~1\temp\tmpxj3mf5\firefox\firefox.exe
2016-04-30T23:30:25: INFO : application_buildid: 20160419050548
2016-04-30T23:30:25: INFO : application_changeset: 2f3a6b7cd4b3e4a70be8b8849d4a9d0a11fe5100
2016-04-30T23:30:25: INFO : application_display_name: Nightly
2016-04-30T23:30:25: INFO : application_id: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
2016-04-30T23:30:25: INFO : application_name: Firefox
2016-04-30T23:30:25: INFO : application_remotingname: firefox
2016-04-30T23:30:25: INFO : application_repository: https://hg.mozilla.org/integration/mozilla-inbound
2016-04-30T23:30:25: INFO : application_vendor: Mozilla
2016-04-30T23:30:25: INFO : application_version: 48.0a1
2016-04-30T23:30:25: INFO : platform_buildid: 20160419050548
2016-04-30T23:30:25: INFO : platform_changeset: 2f3a6b7cd4b3e4a70be8b8849d4a9d0a11fe5100
2016-04-30T23:30:25: INFO : platform_repository: https://hg.mozilla.org/integration/mozilla-inbound
2016-04-30T23:30:25: INFO : platform_version: 48.0a1
2016-04-30T23:30:52: INFO : Narrowed inbound regression window from [53376d36, 7df73cfe] (10 revisions) to [2f3a6b7c, 7df73cfe] (5 revisions) (~2 steps left)
2016-04-30T23:30:52: INFO : Running mozilla-inbound build built on 2016-04-19 14:56:13.377000, revision 68b14d04
2016-04-30T23:30:52: DEBUG : using taskcluster route 'gecko.v2.mozilla-inbound.revision.750ff8b64b21633ccdc2e017d573c552d2ba2268.firefox.win32-opt'
2016-04-30T23:30:56: DEBUG : using taskcluster route 'gecko.v2.mozilla-inbound.revision.894e3c1ce7998d21cb193bdf66817ebd794c11e8.firefox.win32-opt'
2016-04-30T23:31:00: INFO : Launching d:\docume~1\useran~1.000\ustawi~1\temp\tmpb3ctym\firefox\firefox.exe
2016-04-30T23:31:00: INFO : application_buildid: 20160419052148
2016-04-30T23:31:00: INFO : application_changeset: 68b14d04ea4e78be6e905a739df95e74cd1f97fd
2016-04-30T23:31:00: INFO : application_display_name: Nightly
2016-04-30T23:31:00: INFO : application_id: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
2016-04-30T23:31:00: INFO : application_name: Firefox
2016-04-30T23:31:00: INFO : application_remotingname: firefox
2016-04-30T23:31:00: INFO : application_repository: https://hg.mozilla.org/integration/mozilla-inbound
2016-04-30T23:31:00: INFO : application_vendor: Mozilla
2016-04-30T23:31:00: INFO : application_version: 48.0a1
2016-04-30T23:31:00: INFO : platform_buildid: 20160419052148
2016-04-30T23:31:00: INFO : platform_changeset: 68b14d04ea4e78be6e905a739df95e74cd1f97fd
2016-04-30T23:31:00: INFO : platform_repository: https://hg.mozilla.org/integration/mozilla-inbound
2016-04-30T23:31:00: INFO : platform_version: 48.0a1
2016-04-30T23:31:06: WARNING : Process exited with code 255
2016-04-30T23:31:07: INFO : Narrowed inbound regression window from [2f3a6b7c, 7df73cfe] (5 revisions) to [2f3a6b7c, 68b14d04] (3 revisions) (~1 steps left)
2016-04-30T23:31:07: INFO : Running mozilla-inbound build built on 2016-04-19 14:42:01.576000, revision 894e3c1c
2016-04-30T23:31:15: INFO : Launching d:\docume~1\useran~1.000\ustawi~1\temp\tmpbds2gd\firefox\firefox.exe
2016-04-30T23:31:15: INFO : application_buildid: 20160419051052
2016-04-30T23:31:15: INFO : application_changeset: 894e3c1ce7998d21cb193bdf66817ebd794c11e8
2016-04-30T23:31:15: INFO : application_display_name: Nightly
2016-04-30T23:31:15: INFO : application_id: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
2016-04-30T23:31:15: INFO : application_name: Firefox
2016-04-30T23:31:15: INFO : application_remotingname: firefox
2016-04-30T23:31:15: INFO : application_repository: https://hg.mozilla.org/integration/mozilla-inbound
2016-04-30T23:31:15: INFO : application_vendor: Mozilla
2016-04-30T23:31:15: INFO : application_version: 48.0a1
2016-04-30T23:31:15: INFO : platform_buildid: 20160419051052
2016-04-30T23:31:15: INFO : platform_changeset: 894e3c1ce7998d21cb193bdf66817ebd794c11e8
2016-04-30T23:31:15: INFO : platform_repository: https://hg.mozilla.org/integration/mozilla-inbound
2016-04-30T23:31:15: INFO : platform_version: 48.0a1
2016-04-30T23:31:33: INFO : Narrowed inbound regression window from [2f3a6b7c, 68b14d04] (3 revisions) to [894e3c1c, 68b14d04] (2 revisions) (~1 steps left)
2016-04-30T23:31:33: DEBUG : Starting merge handling...
2016-04-30T23:31:33: DEBUG : Using url: https://hg.mozilla.org/integration/mozilla-inbound/json-pushes?changeset=68b14d04ea4e78be6e905a739df95e74cd1f97fd&full=1
2016-04-30T23:31:34: DEBUG : Found commit message:
Bug 1265399 - Replace 0.7071 with sqrt(0.5) in downmixing equations; r=padenot

MozReview-Commit-ID: 8hiiqJ0yIxm

2016-04-30T23:31:34: INFO : The bisection is done.
2016-04-30T23:31:34: INFO : Stopped
[Tracking Requested - why for this release]:

gps, does this fit with the MSVC upgrade and if so can you investigate?
Component: XPCOM → Build Config
Flags: needinfo?(gps)
Bug 1265615 is the only VS2015 related issue I'm aware of. It is manifesting as a crash when attempting to execute SSE instructions on machines without those instructions. That seems to fit the first few comments in this bug.

"Couldn't load XPCOM" is much, much earlier in the startup sequence, which /may/ indicate a different issue or different manifestation of the same issue, however.

I'm skeptical that changeset 68b14d04 regressed things, as it is a simple change to introduce sqrt(). And a casual look seems to indicate that this is code that would run in the compiler and not at run time. So I'm not sure how that would cause this failure.

It would be really nice to get a crash dump from this (assuming it is crashing - I think "Couldn't load XPCOM" may just trigger an exit code in some situations). If it isn't crashing, perhaps we could provide a Try build that crashes when "Couldn't load XPCOM" is hit?

I'm not an expert on debugging crashes. Let me ping some other people in IRC...
Flags: needinfo?(gps)
froydnj commented on this in IRC:

18:40 < froydnj> gps: that's a super-odd bisection commit
18:52 < froydnj> gps: it's possible that the sqrt() call is not constant-folded away, so the sqrt() call happens at runtime when we load libxul
18:52 < froydnj> gps: and we're not ready for code from the crt or libm to run, or something?
Status: UNCONFIRMED → NEW
Ever confirmed: true
I'll double check and see what is going on with the sqrt() call. In a small test program on gcc/linux it definitely gets folded away, but that's not conclusive.
That commit is pretty weird, but it's entirely possible that MSVC is not constant-folding away the call to sqrt, which means that it would get executed at library load time, which might have some weird knock-on effects.

I've started a try build:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=948f172f8edb

with the call to sqrt removed.  jukaru, would you mind downloading the binary from:

https://archive.mozilla.org/pub/firefox/try-builds/nfroyd@mozilla.com-948f172f8edbe0365fcbe5beb4f048204cab97ff/

and giving it a spin?  It's possible other bustage has landed in the meantime, since I based off a recent m-c revision, but ideally we'll get some more information.

(In reply to Dan Minor [:dminor] from comment #15)
> I'll double check and see what is going on with the sqrt() call. In a small
> test program on gcc/linux it definitely gets folded away, but that's not
> conclusive.

GCC is a bit unusual in folding away libm functions like that; it's not typically done, AFAIK.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Flags: needinfo?(silence)
(In reply to Nathan Froyd [:froydnj] from comment #16)
> That commit is pretty weird, but it's entirely possible that MSVC is not
> constant-folding away the call to sqrt, which means that it would get
> executed at library load time, which might have some weird knock-on effects.
> 
> I've started a try build:
> 
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=948f172f8edb
> 
> with the call to sqrt removed.  jukaru, would you mind downloading the
> binary from:
> 
> https://archive.mozilla.org/pub/firefox/try-builds/nfroyd@mozilla.com-
> 948f172f8edbe0365fcbe5beb4f048204cab97ff/
> 
> and giving it a spin?  It's possible other bustage has landed in the
> meantime, since I based off a recent m-c revision, but ideally we'll get
> some more information.
> 
I just try this build, and it work for me ;)
(In reply to patclash from comment #17)
> (In reply to Nathan Froyd [:froydnj] from comment #16)
> > That commit is pretty weird, but it's entirely possible that MSVC is not
> > constant-folding away the call to sqrt, which means that it would get
> > executed at library load time, which might have some weird knock-on effects.
> > 
> > I've started a try build:
> > 
> > https://treeherder.mozilla.org/#/jobs?repo=try&revision=948f172f8edb
> > 
> > with the call to sqrt removed.  jukaru, would you mind downloading the
> > binary from:
> > 
> > https://archive.mozilla.org/pub/firefox/try-builds/nfroyd@mozilla.com-
> > 948f172f8edbe0365fcbe5beb4f048204cab97ff/
> > 
> > and giving it a spin?  It's possible other bustage has landed in the
> > meantime, since I based off a recent m-c revision, but ideally we'll get
> > some more information.
> > 
> I just try this build, and it work for me ;)

Thanks for trying it out!

Seems like the manual constant fold is the way to go.
Some compilers constant-fold the sqrt call away, but MSVC apparently
does not, and the call to sqrt at library load time causes issues.
Attachment #8749210 - Flags: review?(dminor)
Comment on attachment 8749210 [details] [diff] [review]
manually constant-fold sqrt call for SQRT_ONE_HALF definition

Review of attachment 8749210 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the fix!
Attachment #8749210 - Flags: review?(dminor) → review+
(In reply to Nathan Froyd [:froydnj] from comment #16)

> with the call to sqrt removed.  jukaru, would you mind downloading the
> binary from:
> 
> https://archive.mozilla.org/pub/firefox/try-builds/nfroyd@mozilla.com-
> 948f172f8edbe0365fcbe5beb4f048204cab97ff/
> 
> and giving it a spin?  It's possible other bustage has landed in the
> meantime, since I based off a recent m-c revision, but ideally we'll get
> some more information.

Yes, for me too. This version working fine
https://hg.mozilla.org/mozilla-central/rev/ffce4cb69e30
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
Flags: needinfo?(silence)
Comment on attachment 8749210 [details] [diff] [review]
manually constant-fold sqrt call for SQRT_ONE_HALF definition

I apparently reset the tracking flags, sorry about that. :(

Approval Request Comment
[Feature/regressing bug #]: bug 1265399
[User impact if declined]: Some windows users won't be able to start the browser
[Describe test coverage new/current, TreeHerder]: yes
[Risks and why]: very low risk
[String/UUID change made/needed]: none
Attachment #8749210 - Flags: approval-mozilla-aurora?
Restoring the tracking flags.
Assignee: nobody → nfroyd
This bug is marked as resolved on Firefox 49, but what about 48 ? 
I just try to update 47.0a2 to 48.0a2 , and this is not landed :( )
Flags: needinfo?(nfroyd)
(In reply to patclash from comment #26)
> This bug is marked as resolved on Firefox 49, but what about 48 ? 
> I just try to update 47.0a2 to 48.0a2 , and this is not landed :( )

The patch is still waiting on approval for 48.
Flags: needinfo?(nfroyd)
maybe this can be reverted again once support for systems without sse2 support is dropped.
Depends on: 1271755
Comment on attachment 8749210 [details] [diff] [review]
manually constant-fold sqrt call for SQRT_ONE_HALF definition

Fixing the issue can help windows users to open Firefox correctly.
Take it in aurora.
Attachment #8749210 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(In reply to philipp from comment #28)
> maybe this can be reverted again once support for systems without sse2
> support is dropped.

I don't see any evidence that this bug has anything to do with SSE2 support.
No longer depends on: 1271755
(In reply to Nathan Froyd [:froydnj] from comment #30)
> I don't see any evidence that this bug has anything to do with SSE2 support.

OK, I was just going by the initial comments of the two reporters. Sorry if this isn't the case.
I just update Aurora with 20160521004015 build and all run well :)

Will this bug automatikely landed on comm-aurora, or do I fill a new bug ?
Flags: needinfo?(nfroyd)
(In reply to patclash from comment #33)
> I just update Aurora with 20160521004015 build and all run well :)

Excellent, thanks for confirming.

> Will this bug automatikely landed on comm-aurora, or do I fill a new bug ?

I don't know anything about how comm-aurora is managed, sorry!  I suspect you have to file a new bug.
Flags: needinfo?(nfroyd)
(In reply to Nathan Froyd [:froydnj] from comment #34)
> (In reply to patclash from comment #33)
> > I just update Aurora with 20160521004015 build and all run well :)
> 
> Excellent, thanks for confirming.
> 
> > Will this bug automatikely landed on comm-aurora, or do I fill a new bug ?
> 
> I don't know anything about how comm-aurora is managed, sorry!  I suspect
> you have to file a new bug.

No necessary filling a bug for Earlybird, the patch is landed too in the today build :)
(I just try to update and all well)
Thank again for this fix
After yesterday update another problem with Nightly 49. Firefox won't run. Show The Application failed to initialize properly (0xc000001d)
I must create another bug issue?
(In reply to jukaru from comment #36)
> After yesterday update another problem with Nightly 49. Firefox won't run.
> Show The Application failed to initialize properly (0xc000001d)
> I must create another bug issue?

support for non-sse2 systems will be officially dropped in firefox 49 - see bug 1271755
(In reply to [:philipp] from comment #37)

> support for non-sse2 systems will be officially dropped in firefox 49 - see
> bug 1271755

Will this affect ESR when update from 45 to 52 ?
(In reply to patclash from comment #38)
> Will this affect ESR when update from 45 to 52 ?

Yes.  You will not be able to upgrade to ESR 52 if you have a system that doesn't support SSE2.
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.