3.52 - 5.53% damp (linux64, windows8-64) regression on push d42b25947fc2 (Wed Apr 20 2016)

RESOLVED WONTFIX

Status

DevTools
General
P1
normal
RESOLVED WONTFIX
2 years ago
a month ago

People

(Reporter: jmaher, Unassigned)

Tracking

({perf, regression})

Trunk
perf, regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [talos_regression][btpp-fix-now])

(Reporter)

Description

2 years ago
Talos has detected a Firefox performance regression from push d42b25947fc2. As author of one of the patches included in that push, we need your help to address this regression.

This is a list of all known regressions and improvements related to the push:
https://treeherder.mozilla.org/perf.html#/alerts?id=967

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see:
https://wiki.mozilla.org/Buildbot/Talos/Tests#DAMP

Reproducing and debugging the regression:
If you would like to re-run this Talos test on a potential fix, use try with the following syntax:
try: -b o -p win64,linux64 -u none -t g2-e10s[Windows 8],g2[Windows 8] --rebuild 5  # add "mozharness: --spsProfile" to generate profile data

(we suggest --rebuild 5 to be more confident in the results)

To run the test locally and do a more in-depth investigation, first set up a local Talos environment:
https://wiki.mozilla.lorg/Buildbot/Talos/Running#Running_locally_-_Source_Code

Then run the following command from the directory where you set up Talos:
talos --develop -e [path]/firefox -a damp

(add --e10s to run tests in e10s mode)

Making a decision:
As the patch author we need your feedback to help us handle this regression.
*** Please let us know your plans by Wednesday, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations:
https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
(Reporter)

Comment 1

2 years ago
this bug is sort of hard to figure out, but retriggers didn't help me find the root cause, so I just looked at commits in the small range to come up with bug 1244054.  The graphs show a regression, yet with retriggers it isn't clear.  Linux is the clearest case of the bunch.

:Honza, can you take a look at this and help determine if this is the root cause.  If you would like me to try a backout on try to see if that helps, I can do that.  Possibly this is something we need to accept or there is a small fix or two we can do to reduce this.
Component: Untriaged → Developer Tools
Flags: needinfo?(odvarko)
This could be related to bug 1267323
See Also: → bug 1267323
Priority: -- → P1
Whiteboard: [talos_regression] → [talos_regression][btpp-fix-now]
@Brian
Flags: needinfo?(odvarko)
(sorry, pressed enter too soon)

@Brian: is this related to bug 1267323 or it needs more analyses? Can you look at it?

Honza
This push doesn't look like it would cause any regressions: https://hg.mozilla.org/integration/fx-team/rev/d42b25947fc2.  I'm guessing this is intertwined with Bug 1267323
(Reporter)

Comment 6

2 years ago
I believe this regression is on beta now, not sure if there is much we can do.
(In reply to Joel Maher (:jmaher) from comment #6)
> I believe this regression is on beta now, not sure if there is much we can
> do.

Yeah, I'm fine with closing it out
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
Version: unspecified → Trunk

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.