Closed Bug 1267100 Opened 4 years ago Closed 4 years ago

"Assertion failure: IsCurrent()" in mozilla::gl::GLContext::BeforeGLCall

Categories

(Core :: Canvas: WebGL, defect)

defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla49
Tracking Status
firefox48 --- affected
firefox49 --- fixed

People

(Reporter: jruderman, Assigned: jerry)

Details

(Keywords: assertion, testcase, Whiteboard: [gfx-noted])

Attachments

(4 files)

Attached file testcase
No description provided.
Attached file stack
I will work on this.
Assignee: nobody → hshih
Status: NEW → ASSIGNED
Whiteboard: [gfx-noted]
I think we miss the makeCurrent() call.
Attachment #8745183 - Flags: review?(jgilbert)
Attachment #8745183 - Flags: review?(jgilbert) → review+
Attachment #8745184 - Flags: review?(jgilbert) → review+
Backed out for unexpected passes in test_conformance__glsl__misc__shaders-with-name-conflicts.html

Backouts:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1fa73458c212
https://hg.mozilla.org/integration/mozilla-inbound/rev/0ff462dbae75

Push with issues: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=54b1f93e6b73e40cbf04dbb2f03d37714b89f695
Log: https://treeherder.mozilla.org/logviewer.html#?job_id=26730703&repo=mozilla-inbound
08:57:57     INFO -  589 INFO TEST-START | dom/canvas/test/webgl-conf/generated/test_conformance__glsl__misc__shaders-with-name-conflicts.html
08:57:57     INFO -  JavaScript warning: http://mochi.test:8888/tests/dom/canvas/test/webgl-conf/checkout/conformance/resources/glsl-conformance-test.js, line 169: Error: WebGL: linkProgram: Failed to link, leaving the following log:
08:57:57     INFO -  The uniform name (foo) conflicts with attribute name.
08:57:57     INFO -  590 INFO TEST-FAIL | dom/canvas/test/webgl-conf/generated/test_conformance__glsl__misc__shaders-with-name-conflicts.html | A valid string reason is expected
08:57:57     INFO -  591 INFO TEST-FAIL | dom/canvas/test/webgl-conf/generated/test_conformance__glsl__misc__shaders-with-name-conflicts.html | Reason cannot be empty
08:57:57     INFO -  592 INFO TEST-FAIL | dom/canvas/test/webgl-conf/generated/test_conformance__glsl__misc__shaders-with-name-conflicts.html | shaders with conflicting uniform/attribute names should fail
08:57:57     INFO -  593 INFO TEST-FAIL | dom/canvas/test/webgl-conf/generated/test_conformance__glsl__misc__shaders-with-name-conflicts.html | successfullyParsed is true
08:57:57     INFO -  594 INFO TEST-UNEXPECTED-PASS | dom/canvas/test/webgl-conf/generated/test_conformance__glsl__misc__shaders-with-name-conflicts.html | fail-if condition in manifest - We expected at least one failure
Flags: needinfo?(hshih)
Unfortunately, the backouts weren't necessary. The WebGL errors had been caused by a different patch, so I relanded these.
Flags: needinfo?(hshih)
https://hg.mozilla.org/mozilla-central/rev/7b63f81d72fb
https://hg.mozilla.org/mozilla-central/rev/a4a7d5ed6da1
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
You need to log in before you can comment on or make changes to this bug.