Closed Bug 1267253 Opened 4 years ago Closed 4 years ago

Delete gfxWindowsPlatform::RenderMode and replace it with a check against the default backend

Categories

(Core :: Graphics, defect)

47 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla49
Tracking Status
firefox49 --- fixed

People

(Reporter: mchang, Assigned: mchang)

References

Details

(Whiteboard: gfx-noted)

Attachments

(1 file)

Delete references to gfxWindowsPlatform::RenderMode [1] since it assumes we use d2d as long as it's available, but we could still not use d2d if the backend prefs are different. This is causing some skia reftest failures.

[1] https://dxr.mozilla.org/mozilla-central/source/gfx/thebes/gfxWindowsPlatform.h?case=true&from=gfxWindowsPlatform.h#123
Whiteboard: gfx-noted
Try looks good I think - https://treeherder.mozilla.org/#/jobs?repo=try&revision=1bdc470cdf39 - #releng said we can ignore the windows 7 gfx vms.
Attachment #8744909 - Flags: review?(bas)
Comment on attachment 8744909 [details] [diff] [review]
Delete gfxWindowsPlatform::RenderMode

Review of attachment 8744909 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/thebes/gfxUtils.cpp
@@ +400,5 @@
>  static CompositionOp
>  OptimalFillOp()
>  {
>  #ifdef XP_WIN
> +    if (gfxWindowsPlatform::GetPlatform()->IsDirect2DBackend()) {

We should really base this on the DT we're actually drawing to. But that should be a follow-up.
Attachment #8744909 - Flags: review?(bas) → review+
Duplicate of this bug: 1265501
https://hg.mozilla.org/mozilla-central/rev/32ea86eb7d9f
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
If I force CreateBlendState() to fail in CompositorD3D11::Initialize() (just return false, regardless of the result of that call), I end up with D2D and basic compositor.  Is that a result of this patch, or was it bad before?
Flags: needinfo?(mchang)
Backed out this patch, this is still there.  I'll open a bug.
Flags: needinfo?(mchang)
You need to log in before you can comment on or make changes to this bug.