extra characters in Mozilla Bug Reporting Form

VERIFIED FIXED in Bugzilla old

Status

()

Bugzilla
Bugzilla-General
P1
normal
VERIFIED FIXED
17 years ago
8 years ago

People

(Reporter: Brant Gurganus, Assigned: kinmoz)

Tracking

unspecified
Bugzilla old
x86
Windows XP

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.8+)
Gecko/20020217
BuildID:    2002021708

There appears to be extra characters in the Bug Reporting Form at
<http://www.mozilla.org/quality/help/bugzilla-helper.html>.  The specific form
element is textarea used for "Steps to Reproduce".

Reproducible: Always
Steps to Reproduce:
1. Load the example page.
2. Put the insertion point after "3.".
3. Press BACKSPACE twice. (notice where the insertion point is)
4. Type something.

Actual Results:  The typed words appear on the third line.

Expected Results:  Either
One: The insertion point remains on the third line.
or
Two: The hidden character is deleted after the second BACKSPACE.

The code in the page is:
<textarea rows=5 cols=70 name=ReproduceSteps wrap=virtual></textarea>.

From this, I don't know where the numbering comes from in the first place.

Upon further inspection, I saw this line:
<script type="text/javascript" language="JavaScript1.2"
src="./bugreport.js"></script>

This makes me believe the culprit is actually JavaScript, but I don't know.

Comment 1

17 years ago
confirmed
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
strange but not deadly. It looks like script may be adding this text omto the
textarea.
Assignee: rods → kin
Priority: -- → P1
Target Milestone: --- → Future
(Reporter)

Comment 3

16 years ago
Changing to more appropriate product.
Component: HTML Form Controls → Bugzilla Helper
Product: Browser → Webtools
Target Milestone: Future → ---
(Reporter)

Comment 4

16 years ago
This seems to be fixed now.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Webtools/Bugzilla Helper is being retired.
Component: Bugzilla Helper → Bugzilla-General
Product: Webtools → Bugzilla
Target Milestone: --- → Bugzilla old
Version: other → unspecified
(Reporter)

Comment 6

15 years ago
v
Status: RESOLVED → VERIFIED

Updated

8 years ago
QA Contact: madhur → default-qa
You need to log in before you can comment on or make changes to this bug.