bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[Widevine] Reload is not properly done on Amazon videos in non-e10s

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: Playback
P3
normal
Rank:
19
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: alindeac, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
All
Windows
Points:
---

Firefox Tracking Flags

(e10s-, platform-rel +, firefox46 unaffected, firefox47 ?, firefox48 ?, firefox49 affected, firefox50 verified, firefox53 verified)

Details

(Whiteboard: [platform-rel-Amazon][platform-rel-AmazonVideo])

Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160425102203

[Note]:
Widevine Content Decryption Module provided by Google is installed and enabled.
Primetime Content Decryption Module provided by Adobe Systems is disabled.

[Affected versions]:
Nightly 49.0a1
Aurora 48.0a2
Firefox 47 Beta 1 

[Affected platforms]:
Windows 7 x64bit
Windows 8 x64bit
Windows 10

[Steps to reproduce]:
1. Launch Firefox with a new profile
2. Wait for Widevine to get installed in about:addons/plugins
3. In the Navigation bar, click on Open Menu button and select Options
4. Disable e10s by un-checking "Enable multi-process Firefox Developer Edition" 
5. Click on the OK button when prompted to Restart Firefox
6. Login to Amazon and go to the TV Shows section
http://www.amazon.com/b/ref=sv_atv_0?_encoding=UTF8&node=2864549011
7. Hover your mouse over any video and middle click on Watch now/Resume button
8. Watch the video for a little time and Reload the video (by hitting the F5 key or Ctrl+F5 keys or click on the Reload button from the Navigation Bar)


[Expected result]:
The video should resume from the moment the Reload action was initiated in step 8.

[Actual result]:
The video resumes from the moment the video was started/resumed in step 7.

[Regression range]:
Not a regression.

[Additional notes]:
The issue is not reproducible on Mac OSes.
The issue is not reproducible when e10s is enabled on any of the platforms with any of the above mentioned Firefox versions.
The issue is not reproducible on other browsers, for e.g Chrome 50.0.2661.87 m (64-bit).
Blocks: 1265270
status-firefox46: --- → unaffected
status-firefox47: --- → ?
status-firefox48: --- → ?

Updated

2 years ago
tracking-e10s: --- → -
I don't think this is a Firefox bug.

I can repro this problem with Widevine on Windows 10 (without e10s), but I can also repro with Silverlight on Windows 10 and OS X *and* in Safari on OS X. This sounds like a write race condition during page shutdown. I'll ask Amazon what the expected behavior is, but there's probably not much we can do.
No longer blocks: 1265270
Priority: -- → P2
Mass change P2 -> P3
Priority: P2 → P3
platform-rel: --- → ?
Whiteboard: [platform-rel-Amazon][platform-rel-AmazonVideo]

Updated

2 years ago
platform-rel: ? → +

Updated

2 years ago
Rank: 19
Chris - did you reach out to the Amazon Video team for feedback? And if so - did they confirm that this is something on their end?
Flags: needinfo?(cpeterson)
(In reply to Desigan Chinniah [:cyberdees] [:dees] [London - GMT] from comment #3)
> Chris - did you reach out to the Amazon Video team for feedback? And if so -
> did they confirm that this is something on their end?

I reported this bug to Amazon on 2016-05-02, but didn't receive a response.

I just tested Firefox 50 and 53 and I can no longer reproduce this problem, so either Firefox 50 fixed something or Amazon changed their site.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox50: --- → verified
status-firefox53: --- → verified
Flags: needinfo?(cpeterson)
Resolution: --- → WORKSFORME
(In reply to Chris Peterson (out until January 2) [:cpeterson] from comment #4)
> (In reply to Desigan Chinniah [:cyberdees] [:dees] [London - GMT] from
> comment #3)
> > Chris - did you reach out to the Amazon Video team for feedback? And if so -
> > did they confirm that this is something on their end?
> 
> I reported this bug to Amazon on 2016-05-02, but didn't receive a response.
> 
> I just tested Firefox 50 and 53 and I can no longer reproduce this problem,
> so either Firefox 50 fixed something or Amazon changed their site.

Good to verify it's fixed. Thanks, Chris.

Minor note that the Amazon DL was created post 2016-05, so if this or anything else comes up going forward we have a hopefully more reactive channel to reach out to them.
You need to log in before you can comment on or make changes to this bug.