Closed Bug 1267666 Opened 5 years ago Closed 9 months ago

Trying to view or change Lightning extension options in Add-ons Manager hangs Seamonkey

Categories

(SeaMonkey :: MailNews: General, defect)

defect
Not set
normal

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53+ fixed, seamonkey2.57esr? affected)

RESOLVED FIXED
seamonkey2.53
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 + fixed
seamonkey2.57esr ? affected

People

(Reporter: frg, Assigned: iann_bugzilla)

References

Details

(Keywords: addon-compat, calendar-integration, hang, Whiteboard: SM2.53.3)

Attachments

(4 files)

Attached image Clipboard.jpg
If you press the 'Options' button for Lightning in about:addons Seamonkey hangs. See screenshot for button location.

Using Options button from the Extensions list works so does using the preferences dialog.
Keywords: hang
See Bug 636104 - Redirect Lightning Preferences to the Suite Preferences window.
Bug 636104 redirected the main Options button. But the Detail View section has another Options button.

<button id="detail-prefs-btn" class="addon-control preferences"
........
        command="cmd_showItemPreferences"/>
Depends on: 636104
I can't confirm the hang with 2.45a2 build from 20160429.

What I can confirm with that build is, that after clicking on "Options" nothing happens (but, as said, SeaMonkey does not hang).
Here (Seamonkey 2.40, Lightning 4.5b1, Windows NT 6.1, WOW64) it does happen - the current window gets "locked":

- Open a new browser window, press Ctrl-Shift-A to open Add-on-manager,
- select Lightning Add-On and click "Options".

It seems that the preferences dialog gets the focus (in a "modal dialog" way) yet it stays invisible - meaning that the window is not accessible anymore. (Also the usual error sound is played that occours when one tries to switch away from a modal dialog to an application window.)

Pressing ESC or Alt-F4 to close the invisible dialog does not help.

The only way out seems to be shutting down Seamonkey. (That is, if you happen to have other windows open - note that those don't get blocked.)
Stefan,

using options in the main menu works for me in 2.47 the same as it did in 2.45. It only hangs trying to use options when you doubleclicked on Lightning and use the option button in the second panel there. See screenshot.

Do you see the Calendar preferences in the prefs dialog? If not you might have a corrupted installation.
(In reply to Frank-Rainer Grahl from comment #4)
> Stefan,
> 
> using options in the main menu works for me in 2.47 the same as it did in
> 2.45. It only hangs trying to use options when you doubleclicked on
> Lightning and use the option button in the second panel there. See
> screenshot.
> 
> Do you see the Calendar preferences in the prefs dialog? If not you might
> have a corrupted installation.

yes, opening Calendar preferences over the menu works for me.

I just wanted to point out that unlike comment 3 I can reproduce your bug (clicking on 'Options' button as shown in your screenshot).

Also not my whole application hangs, but only the active window (the one holding the Add-on manager tab), other windows remain responsive. (I was going to report the same bug, but then found this one - so I just commented, hoping the additional information about the nature of the "hanging" might be useful.)
> ... I just wanted to point out that unlike comment 3 I can reproduce your bug ...
sorry - make this "comment 2"

This is reproducible in SeaMonkey 2.53.2. Clicking "Options" from the extension list
works fine, clicking "Options" button from the extension details does not.
Please see the two attached screenshots for more details.

Attached image Options1.png

From here "Options" works fine.

Attached image Options2.png

From here, "Options" does not work.

Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
Component: General → MailNews: General
OS: Unspecified → All
Hardware: Unspecified → All
Version: unspecified → Trunk
Attached patch Fix optionsURLSplinter Review

As we now bundle lightning with SM/TB we can just set the correct optionsURL in install.rdf depending on the application and not have to do any of the complicated stuff we were doing before.

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: prefs/options button doesn't work in add-on details view
Testing completed (on m-c, etc.): 2.53.3
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: none

Attachment #9149737 - Flags: review?(frgrahl)
Attachment #9149737 - Flags: approval-comm-release?
Attachment #9149737 - Flags: approval-comm-esr60?
Comment on attachment 9149737 [details] [diff] [review]
Fix optionsURL

Works fine. 

Given this is only for our 2.53 and 2.57 release branches and our releases would it make sense to also edit out the TB or SM compatibility from install.rdf depending on application?
Attachment #9149737 - Flags: review?(frgrahl)
Attachment #9149737 - Flags: review+
Attachment #9149737 - Flags: approval-comm-release?
Attachment #9149737 - Flags: approval-comm-release+
Attachment #9149737 - Flags: approval-comm-esr60?
Attachment #9149737 - Flags: approval-comm-esr60+
Whiteboard: SM2.53.3

(In reply to Frank-Rainer Grahl (:frg) from comment #11)

Comment on attachment 9149737 [details] [diff] [review]
Fix optionsURL

Works fine.

Given this is only for our 2.53 and 2.57 release branches and our releases
would it make sense to also edit out the TB or SM compatibility from
install.rdf depending on application?

Perhaps, but it works as is so happy to leave it alone.

Target 2.53.3
https://gitlab.com/seamonkey-project/seamonkey-2.53-comm/-/commit/811074d7ba4cb8baa8390f8d3431c0c61406bcdd

Marking 2.57 as affected but the options are no longer working from the add-on manager there. Might need another fix or backout of a toolkit "feature" later.

Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.53
You need to log in before you can comment on or make changes to this bug.