Closed Bug 1267817 Opened 4 years ago Closed 4 years ago

[Omnibox] Add support for chrome.omnibox.setDefaultSuggestion

Categories

(WebExtensions :: Frontend, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1267810

People

(Reporter: mattw, Unassigned)

Details

(Whiteboard: [omnibox]triaged)

This bug is meant to track the implementation and testing of chrome.omnibox.setDefaultSuggestion.

Chrome docs: https://developer.chrome.com/extensions/omnibox#method-setDefaultSuggestion
This sounds like it is going to require UI changes to our search UI, which gives me pause. I'm not sure it's worth implementing this on Android.
Margaret, I'm working to implement this only on desktop for chrome parity. I used one of my PageAction bugs as a template and forgot to unset the Platform...  I'm really sorry for the confusion.
OS: Android → Unspecified
Whiteboard: triaged → [omnibox]triaged
No worries, thanks for clarifying!
Component: WebExtensions: Untriaged → WebExtensions: Frontend
Priority: -- → P3
No longer blocks: 1166831
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1267810
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.