Multiple times now I've been tricked by the fact that nsNetUtil.inl is actually C++ code. E.g. if you look for a code pattern through all .h and .cpp files, you'll miss ones that occur in this file. There's a precedent in layout/ of using a "Inlines.h" suffix for this kind of file, which I propose we adopt for this file.
Comment on attachment 8745845 [details] [diff] [review] Rename nsNetUtil.inl as nsNetUtilInlines.h Looks good. Thanks!
Attachment #8745845 - Flags: review?(valentin.gosu) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/28f944410c7fdf27f7ddf16fc01be4eb0a6eade8 Bug 1267912 - Rename nsNetUtil.inl as nsNetUtilInlines.h. r=valentin.
You need to log in before you can comment on or make changes to this bug.