XSLT -files are not always refreshed

RESOLVED DUPLICATE of bug 186224

Status

()

Core
XML
RESOLVED DUPLICATE of bug 186224
16 years ago
15 years ago

People

(Reporter: Sami Haahtinen, Assigned: Heikki Toivonen (remove -bugzilla when emailing directly))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8+)
Gecko/20020220
BuildID:    2002022003

stylesheet doesn't get updated with reload if it has been loaded to cache 
before mozilla has been started.

Reproducible: Always
Steps to Reproduce:
1.create a simple xml test document.
2.create a simple xslt -file.
3.fire it up in the browser and look at it... (looks nice, doesn't it)
4.restart mozilla
5.view the document again.
6.modify the XSLT -file.
7.press reload

Actual Results:  xml document gets reloaded but the new XSLT -template doesn't.
mozilla uses the old one instead

Expected Results:  xml and xslt files get refreshed.

if you load the xslt file to browser and press reload, then go back to the xml
file and change the xslt reload works as supposed to.

Comment 1

16 years ago
confirming this one. Over to networking/cache. kvisco on CC so that all the 
XSLT watchers get the info.
Assignee: kvisco → gordon
Status: UNCONFIRMED → NEW
Component: XSLT → Networking: Cache
Ever confirmed: true
QA Contact: kvisco → tever

Comment 2

16 years ago
I presume you're using HTTP to access this file?
Assignee: gordon → darin
Component: Networking: Cache → Networking: HTTP

Comment 3

16 years ago
sounds like a problem in the code that initiates the download of the XSLT file.
not a networking bug per se, but a misuse of our API.

would love to reassign this to whomever owns the XML/XSLT code.

Comment 4

16 years ago
-> peterv
Assignee: darin → peterv
Component: Networking: HTTP → XML
note to peterv: the syncloader might have the same problem

Comment 6

15 years ago
Bug 155715 may be related.

Comment 7

15 years ago
-> defaults
Assignee: peterv → heikki
QA Contact: tever → ashishbhatt
sorry for dupping the wrong way, but bug 186224 contains more info

*** This bug has been marked as a duplicate of 186224 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.