[oxygen-gtk3] Firefox 46 crashes on CentOS 7 upon startup

RESOLVED DUPLICATE of bug 1268185

Status

()

RESOLVED DUPLICATE of bug 1268185
3 years ago
3 years ago

People

(Reporter: ondrej.mikle, Unassigned)

Tracking

46 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160426213406

Steps to reproduce:

Start Firefox 46 on CentOS 7 x86_64.


Actual results:

Firefox crashed in libgtk3. The crash happens even on clean profile and also in safe mode.

Program received signal SIGSEGV, Segmentation fault.

#0  0x00007fffd6bba9e6 in Oxygen::render_frame(_GtkThemingEngine*, _cairo*, double, double, double, double) () at /usr/lib64/gtk-3.0/3.0.0/theming-engines/liboxygen-gtk.so
#1  0x00007ffff4bc8cde in gtk_render_frame () at /lib64/libgtk-3.so.0
#2  0x00007fffe95a9ea6 in  () at /home/ondro/local/firefox/libxul.so
#3  0x00007fffe95d3da3 in  () at /home/ondro/local/firefox/libxul.so
#4  0x00007fffe96f0e7a in  () at /home/ondro/local/firefox/libxul.so
#5  0x00007fffe80cbde0 in  () at /home/ondro/local/firefox/libxul.so
#6  0x00007fffe96dfcfd in  () at /home/ondro/local/firefox/libxul.so
#7  0x00007fffe895bf67 in  () at /home/ondro/local/firefox/libxul.so
#8  0x00007fffe8961846 in  () at /home/ondro/local/firefox/libxul.so
#9  0x00007fffe895ba6b in  () at /home/ondro/local/firefox/libxul.so
#10 0x00007fffe8957029 in  () at /home/ondro/local/firefox/libxul.so
#11 0x00007fffe8961f08 in  () at /home/ondro/local/firefox/libxul.so
#12 0x00007fffe97042a0 in  () at /home/ondro/local/firefox/libxul.so
#13 0x00007fffe9739137 in  () at /home/ondro/local/firefox/libxul.so
#14 0x00007fffe9740087 in  () at /home/ondro/local/firefox/libxul.so
#15 0x00007fffe95873fb in  () at /home/ondro/local/firefox/libxul.so
#16 0x00007fffe9587653 in  () at /home/ondro/local/firefox/libxul.so
#17 0x00007fffe96cd1bc in  () at /home/ondro/local/firefox/libxul.so
#18 0x00007fffe96cdfe8 in  () at /home/ondro/local/firefox/libxul.so
#19 0x00007fffe96ce06c in  () at /home/ondro/local/firefox/libxul.so
#20 0x00007fffe96ce199 in  () at /home/ondro/local/firefox/libxul.so
#21 0x00007fffe96ce1ef in  () at /home/ondro/local/firefox/libxul.so
#22 0x00007fffe7fd31f1 in  () at /home/ondro/local/firefox/libxul.so
#23 0x00007fffe7fdb2ba in  () at /home/ondro/local/firefox/libxul.so
#24 0x00007fffe7ff36c3 in  () at /home/ondro/local/firefox/libxul.so
#25 0x00007fffe85462b2 in  () at /home/ondro/local/firefox/libxul.so
#26 0x00007fffe959a205 in  () at /home/ondro/local/firefox/libxul.so
#27 0x00007fffe9b4fb53 in  () at /home/ondro/local/firefox/libxul.so
#28 0x00007fffe9b855a2 in  () at /home/ondro/local/firefox/libxul.so
#29 0x00007fffe9b87cf1 in  () at /home/ondro/local/firefox/libxul.so
#30 0x00007fffe9b87f6d in XRE_main () at /home/ondro/local/firefox/libxul.so
#31 0x0000000000408b9b in _start ()




Expected results:

Firefox should start normally.
(Reporter)

Updated

3 years ago
Version: 45 Branch → 46 Branch
(Reporter)

Updated

3 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Updated

3 years ago
Blocks: 627699
Component: Untriaged → Widget: Gtk
Product: Firefox → Core

Comment 1

3 years ago
Similar to bug 1267815, I guess.
(Reporter)

Comment 2

3 years ago
No, the gtk3 library is present in this case, as is evident from the stack trace (stack frame 1).

$ ls -l /lib64/libgtk-3.so.0
lrwxrwxrwx. 1 root root 21 Feb 10 13:09 /lib64/libgtk-3.so.0 -> libgtk-3.so.0.1400.13
http://distrowatch.com/table.php?distribution=centos says the GTK3 version is 3.14 on CentOS 7.  Is that still correct?

I'm not clear whether the oxygen-gtk engine is meant to be used with that version or not.  Do other GTK3 apps run fine?

http://www.phoronix.com/scan.php?page=news_item&px=oxygen-gtk3-killing
https://bugzilla.gnome.org/show_bug.cgi?id=735211

A workaround is to change theme.
Summary: Firefox 46 crashes on CentOS 7 upon startup → [oxygen-gtk3] Firefox 46 crashes on CentOS 7 upon startup
(Reporter)

Comment 4

3 years ago
Yes, GTK3 on CentOS 7 has currently version 3.14.13.

Switching the oxygen theme seems to work as a workaround. I'll just add a way how to change the theme for anyone that googles this bug: in KDE it's in System Settings / Application Appearance / GTK+ Appearance. Choose theme other than oxygen-gtk.

As for other GTK3 applications: I've tried firewall-config, and it runs fine with oxygen-gtk theme.
This would be the same issue as bug 1268185.  I'll dupe forward because that one has attracted more attention.

http://vault.centos.org/7.2.1511/os/Source/SPackages/
has oxygen-gtk3-1.1.4-3.el7.src.rpm, which is affected.

Fedora applied a fix [1], so I expect RHEL will get the fix at some stage.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1065099
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1268185
You need to log in before you can comment on or make changes to this bug.