Closed Bug 1268029 Opened 3 years ago Closed 3 years ago

Use jit classifier to change signature for jit crashes

Categories

(Socorro :: Backend, task)

task
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ted, Assigned: adrian)

References

Details

Attachments

(1 file)

bug 1124241 added classification of JIT crashes using the output of the `jit-crash-categorize` tool that's in the Socorro tree:
https://github.com/mozilla/socorro/blob/master/minidump-stackwalk/jit-crash-categorize.cc

This is working in production, you can look at the processed crash output and see the entry under "classifications":
https://crash-stats.mozilla.com/api/ProcessedCrash/?crash_id=064b61dd-ef54-434b-b743-344872160421

It never got hooked up to change the resulting crash signature, however, which makes it hard to do anything useful with it.

We should make this generate new signatures, as per bug 1124241 comment 2. In that comment I suggested `[@ jit | <reason> ]`, but I'm not wedded to that proposal, and someone who does more crash analysis, or someone who works on the JIT might have a better suggestion.
That sounds reasonable to me, we can see how it turns out and refine if needed. Thanks for filing this!
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/fac69f51f8be21668447145b809dca994cad1623
Fixes bug 1268029 - Added a Rule to replace a signature if there is a JIT classification. (#3314)

r=peterbe
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Duplicate of this bug: 764223
You need to log in before you can comment on or make changes to this bug.