Cannot create new event in Zoho CalDAV calendar [Error: CalDAV: Unexpected status adding item: 409]

RESOLVED INVALID

Status

Calendar
Provider: CalDAV
--
major
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: Marc, Unassigned)

Tracking

Lightning 4.7
x86_64
Windows 10

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8746086 [details]
Capture.PNG

User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.75 Safari/537.36

Steps to reproduce:

Automatically upgraded to Thunderbird 45.0 and Lightning 4.7
After restart the calendar is still synchronizing ok (showing existing entries) but does not let me create new Events
The calendar is synchronized with a Zoho Calendar through CalDAV (the synch works ok)
In calendar options: Read Only is unchecked, Show Reminders is checked, Offline Support is checked.


Actual results:

Nothing, it just does not create any event. No error showing


Expected results:

A new Event should be created in the CalDAV synchronized calendar and in Lightning

(Note: an event created online in Zoho Calendar would appear in Lightning, hence the synchronisation is indeed working)

Other effect: it is not possible to accept an invite sent from outside.
(Reporter)

Updated

2 years ago
Severity: normal → blocker
Keywords: calendar-integration
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

Comment 1

2 years ago
I don't see how this is blocking development?
Moving to Calendar for further triage.
Severity: blocker → major
Component: General → General
Keywords: calendar-integration
Product: Thunderbird → Calendar
Version: 45 Branch → Lightning 4.7
(Reporter)

Updated

2 years ago
Component: General → Provider: CalDAV
(Reporter)

Comment 2

2 years ago
I've posted in the forum as well: https://discourse.mozilla-community.org/t/lightning-caldav-synch-calendar-stuck-in-version-4-7/8379?u=marcwuita

Comment 3

2 years ago
There is also http://forums.mozillazine.org/viewtopic.php?f=46&t=3000893
So, this doesn't appear to be an isolated problem.

Comment 4

2 years ago
Hi Marc, please describe "does not let me create new Events". 

How do you start creating the new event? Does the New Event dialog opens? Or do you use drag and drop? Can you fill in all the information? Can you save the event? Can you close the dialog?

Do you get any error messages reported in Tools > Error Console? Please copy and paste them here. If nothing shows up you can enable additional output by setting the advanced preferences "calendar.debug.log" and "calendar.debug.log.verbose" to "true" using Options > Advanced > General > Config Editor. 

Do you use any other extension, themes or customizations that affect Lightning or its calendars? Could you disable them and retest? Maybe you can copy and paste the extension information from Help > Troubleshooting Information?
Flags: needinfo?(marc)
(Reporter)

Comment 5

2 years ago
(In reply to Stefan Sitter from comment #4)
> Hi Marc, please describe "does not let me create new Events". 
> 
> How do you start creating the new event? Does the New Event dialog opens? Or
> do you use drag and drop? Can you fill in all the information? Can you save
> the event? Can you close the dialog?
> 
> Do you get any error messages reported in Tools > Error Console? Please copy
> and paste them here. If nothing shows up you can enable additional output by
> setting the advanced preferences "calendar.debug.log" and
> "calendar.debug.log.verbose" to "true" using Options > Advanced > General >
> Config Editor. 
> 
> Do you use any other extension, themes or customizations that affect
> Lightning or its calendars? Could you disable them and retest? Maybe you can
> copy and paste the extension information from Help > Troubleshooting
> Information?


Hi
Here are the steps:
- I create a new Event by double-clicking on a day in the calendar in Month view or using the Events & Tasks / New Event menu
- the New Event dialog pops up OK and I can fill all the information
- The dialog closes like normal when I hit Save & Close
- Then the Event is just not created, and wouldn't appear later (so not a slow synch)
- I am not using other extensions in Thunderbird, only Lightning


The Error Console show and error:
Timestamp: 28/04/2016 18:37:19
Error: CalDAV: Unexpected status adding item to Marc - wuita: 409
BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:Europe/London
BEGIN:DAYLIGHT
TZOFFSETFROM:+0000
TZOFFSETTO:+0100
TZNAME:BST
DTSTART:19700329T010000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=3
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0100
TZOFFSETTO:+0000
TZNAME:GMT
DTSTART:19701025T020000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=10
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20160428T173703Z
LAST-MODIFIED:20160428T173718Z
DTSTAMP:20160428T173718Z
UID:acc71f7f-4a68-40a7-9f93-4514d82e0e9f
SUMMARY:test6
DTSTART;TZID=Europe/London:20160511T190000
DTEND;TZID=Europe/London:20160511T200000
TRANSP:OPAQUE
BEGIN:VALARM
ACTION:DISPLAY
TRIGGER;VALUE=DURATION:-PT15M
DESCRIPTION:Default Mozilla Description
END:VALARM
END:VEVENT
END:VCALENDAR

Source File: file:///C:/Users/Marc/AppData/Roaming/Thunderbird/Profiles/ph2m2fth.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calDavCalendar.js
Line: 699
Flags: needinfo?(marc)

Comment 6

2 years ago
The problem seems that your Zoho CalDAV server reports back with status code 409. Lightning is not expecting this and fails.

Internet tells me that 409 means "Conflict", "Indicates that the request could not be processed because of conflict in the request, such as an edit conflict between multiple simultaneous updates" or "The request could not be completed due to a conflict with the current state of the target resource".

Could you enable the advanced preferences for logging and capture all the messages after saving the event until the error is reported? Maybe the CalDAV experts here know what is wrong when they see all the CalDAV messages that are send from Lightning to Zoho and back.
Summary: Lightning 4.7 CalDAV syn calendar does not let create new Event at all → Cannot create new event in Zoho CalDAV calendar [Error: CalDAV: Unexpected status adding item: 409]
(Reporter)

Comment 7

2 years ago
(In reply to Stefan Sitter from comment #6)
> The problem seems that your Zoho CalDAV server reports back with status code
> 409. Lightning is not expecting this and fails.
> 
> Internet tells me that 409 means "Conflict", "Indicates that the request
> could not be processed because of conflict in the request, such as an edit
> conflict between multiple simultaneous updates" or "The request could not be
> completed due to a conflict with the current state of the target resource".
> 
> Could you enable the advanced preferences for logging and capture all the
> messages after saving the event until the error is reported? Maybe the
> CalDAV experts here know what is wrong when they see all the CalDAV messages
> that are send from Lightning to Zoho and back.


Hi 
Only one message before the error in the log with Advanced Logging:

CalDAV: itemUri.spec = https://calendar.zoho.com/caldav/{my_calendar_id_removed_here}/events/ef463c6e-9db6-429a-bf7c-c292a3022694.ics

Comment 8

2 years ago
Can you please request the zoho support to investigate into this issue as well? The creation of the event is refused serverside and there are no such reports for other caldav servers so far. Maybe they can provide more insight from their logs what type of conflict occured that forces the server to refuse to create the event. The event itself looks ok and passes the usual validators.
Flags: needinfo?(marc)
(Reporter)

Comment 9

2 years ago
I've submitted the same to Zoho support, I'll post the link here when I have it
(Reporter)

Comment 10

2 years ago
Zoho Calendar support just emailed me:

Hi,
Sorry for the inconvenience.
We had identified and resolved this issue, can you check now and let us know your feedback.
Please get back to us for further assistance.

Problem solved !
I've tried to invite accept as well and it works fine now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(marc)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.