Crash when scrolling through photos on Facebook

RESOLVED DUPLICATE of bug 760394

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 760394
2 years ago
2 years ago

People

(Reporter: adamopenweb, Unassigned)

Tracking

46 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(fennec+)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8746650 [details]
fbcrash_logcat.txt

When using Firefox for Android, Facebook will crash while trying to quickly scroll through a persons photo section. I am able to reproduce in 46, 47 and 49 on two different devices.

STR:
- Open Firefox for Android
- Navigate to https://m.facebook.com/JustinPJTrudeau (can be any person on FB with many photos)
- Scroll down to Photos and click "See All"
- FB presents a full screen of thumbnails, scrolling activates lazy loading of more images
- Try to scroll quickly to the first image posted by this person

Expected Results:
You eventually get there

Actual Results:
Firefox hangs at some point, pressing the back button crashes the browser

Video:
https://drive.google.com/file/d/0B5x--Dlt75iqTFJxY283WWQzVGs/view
Associated logcat is attached.
(Reporter)

Updated

2 years ago
tracking-fennec: --- → ?

Comment 1

2 years ago
This is fundamentally a memory problem. The log makes this look like a dupe of bug 760394.
Status: NEW → RESOLVED
tracking-fennec: ? → +
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 760394
You need to log in before you can comment on or make changes to this bug.