The blinking cursor moves to the end of the word when single tapping

RESOLVED WORKSFORME

Status

()

Firefox for Android
Keyboards and IME
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: TYLin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Steps to reproduce on Fennec:
1. Use swift keyboard, and open https://public.etherpad-mozilla.org/p/testforclipboard
2. Single tap in the middle of a word. For example, tap in "ETHERPAD"

Expected results:
The blinking cursor shows in the middle of the word like "ETH|ERPAD"

Actual results:
The blinking cursor moves to the end of the word like "ETHERPAD|"

I cannot reproduce this issue by using built-in Google keyboard.
This is expected, as part of autoSuggest/autoCorrect styling compositions. The caret should always position to the right of the "underline/selection/composition" highlight.

(At one point it would sometimes position in the middle of it, but I think that was a bug we fixed).

See for example Bug 927882 - Standardize TextSelection caret positioning logic for soft keyboards
(Reporter)

Comment 2

2 years ago
> (At one point it would sometimes position in the middle of it, but I think
> that was a bug we fixed).

After the cursor moves to the end of the word the first time, it will be positioned in the middle of the word if I tap the word again.

Mark, thank you for the info. I'll close this.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.