Jumps to Internal HTML References Fail with Certain IMG Tags

RESOLVED DUPLICATE of bug 60307

Status

defect
--
major
RESOLVED DUPLICATE of bug 60307
18 years ago
15 years ago

People

(Reporter: tsipple, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Test environment: OS/2 Warp 4, Fixpack 15, latest kernel, SciTech Display Doctor
SE July 2001, Mozilla build 2002020716, IBM ThinkPad T21, 512 MB memory, modem
connection, MPTS WR08700 plus patch.

Problem is likely applicable to all platforms.  Here's the basic problem...

Assume that page1.html contains the following hyperlink:

<A HREF="page2.html#section5">Click Here</A>

and that page2.html is a relatively long page (more than a screenful) containing
images (GIFs, JPGs, PNGs, etc.) both before and after the section point
(section5).  Assume also that the IMG tags loading these bitmaps do not have
WIDTH/HEIGHT parameters, so that Mozilla has to reflow page elements as
knowledge is gained about the image sizes.  Assume that the images are of
substantial size, at least large enough to warrant shifting text around on the page.

It turns out that, if the user clicks on this hyperlink, she will see the
section 5 paragraph at the top of the page, ready to read... but not for very
long.  As the images load, one by one, this part of the page will move, perhaps
entirely off the display area completely.  Consequently the hyperlink with the
internal reference (#section5) all but fails to produce anything useful, and the
user is left staring at a different part of the page.

There are a couple possible fixes to this problem, I think.  One would be to not
process the #section5 part of the link until after the sizes of all the images
are determined, leaving the user at the top of the page during that time.  The
other fix would be to process the internal reference (#section5 or whatever) as
now, but to do so a second time after all the image sizes are determined, to
reposition the viewing point at the appropriate location.

The web site http://www.mini2.com/forum demonstrates this problem when
navigating to a message thread where users have inserted images, but many other
web sites could exhibit this problem.

I'm not sure if this problem occurs with other page elements as well besides
images, but it's an everyday problem with images at least.
Duplicate of "Images loading above top of window can cause scrolling up (reflow?)"

*** This bug has been marked as a duplicate of 60307 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.