"complex" header missing in config/system-headers

RESOLVED FIXED in Firefox 49

Status

RESOLVED FIXED
3 years ago
9 months ago

People

(Reporter: wiz, Unassigned)

Tracking

Trunk
mozilla49

Firefox Tracking Flags

(firefox49 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8747060 [details] [diff] [review]
patch-config_system-headers

User Agent: Mozilla/5.0 (X11; NetBSD amd64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160428084422

Steps to reproduce:

Compiling on NetBSD-7.99.29/amd64 with gcc-5.3 fails with:

Unified_cpp_dom_media_webaudio1.cpp:(.text+0x19e5): undefined reference to `__c99_cabs'
Unified_cpp_dom_media_webaudio1.cpp:(.text+0x19fa): undefined reference to `__c99_cabs'
../../dom/media/webaudio/Unified_cpp_dom_media_webaudio1.o: In function `mozilla::FFTBlock::AddConstantGroupDelay(double)':
Unified_cpp_dom_media_webaudio1.cpp:(.text+0x1d1d): undefined reference to `__c99_cabs'
../../dom/media/webaudio/Unified_cpp_dom_media_webaudio1.o: In function `mozilla::FFTBlock::ExtractAverageGroupDelay()':
Unified_cpp_dom_media_webaudio1.cpp:(.text+0x1e85): undefined reference to `__c99_cabs'
../../dom/media/webaudio/blink/Unified_cpp_webaudio_blink0.o: In function `WebCore::Biquad::setZeroPolePairs(std::complex<double> const&, std::complex<double> const&)':
Unified_cpp_webaudio_blink0.cpp:(.text+0x122b): undefined reference to `__c99_cabs'
../../dom/media/webaudio/blink/Unified_cpp_webaudio_blink0.o:Unified_cpp_webaudio_blink0.cpp:(.text+0x1259): more undefined references to `__c99_cabs' follow

When adding "complex" to config/system-headers, the problem is fixed.
Suggested patch against trunk from today is attached.


Actual results:

Build failure.


Expected results:

Build succeeds.

Updated

3 years ago
Attachment #8747060 - Attachment is patch: true

Updated

3 years ago
Component: Untriaged → Build Config
Product: Firefox → Core

Updated

3 years ago
Attachment #8747060 - Flags: review?(gps)

Comment 1

3 years ago
Comment on attachment 8747060 [details] [diff] [review]
patch-config_system-headers

Review of attachment 8747060 [details] [diff] [review]:
-----------------------------------------------------------------

Looks sane to me. I'll land this for you.
Attachment #8747060 - Flags: review?(gps) → review+

Comment 3

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a1ca1b805353
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
status-firefox49: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla49

Updated

9 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.