Retina - No drag icon when reordering search engines in preferences

RESOLVED DUPLICATE of bug 933302

Status

()

Core
Event Handling
RESOLVED DUPLICATE of bug 933302
2 years ago
a year ago

People

(Reporter: mkaply, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox49 affected)

Details

(Whiteboard: btpp-followup-2016-05-13)

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
On Mac Retina (haven't tried non Retina), when you go to:

about:preferences#search

and reorder search engines, the mouse pointer doesn't change to indicate something is happening. (On Windows, it shows a drag pointer).

It should show some sort of indicator that the drag is happening.
It is the expected behavior on mac OS X. The mouse pointer does not change when dragging items. You can try reordering bookmarks on safari, for example.
So, I'm closing this bug because it works as expected on the specified OS.
(Reporter)

Comment 2

2 years ago
On Safari reordering bookmarks it shows you dragging the entire item.

On Firefox, we are not showing any drag feedback. So no, this is not working like the OS.
When I drag an item, I can see the entire item dragged (although it's not exactly the same design as safari, because it includes the blue highlight)
Created attachment 8748311 [details]
Screenshot showing drag effect on nightly

Shows the dragging effect on search engine preferences
(Reporter)

Comment 5

2 years ago
Created attachment 8748315 [details]
Drag effect on Retina

I don't see that effect on a Retina nightly.

The drag is happening, but the cursor doesn't change.

It works on non Retina. I tested with the same machine, same browser switching between Retina/non Retina.
(Reporter)

Updated

2 years ago
Summary: No drag icon when reordering search engines in preferences → Retina - No drag icon when reordering search engines in preferences
OK, I did not really get the 'changing' cursor idea. In my mind the shape of the cursor did not change (on windows, it changes to a hand, for example), so I assumed you meant that.
Indeed, it looks like a retina-specific bug
Can you try to reorder bookmarks (in the show all bookmarks or in the bookmarks toolbar)?
It may be not specific to search engines but be a more generic issue.
Flags: needinfo?(mozilla)
(Reporter)

Comment 8

2 years ago
> Can you try to reorder bookmarks (in the show all bookmarks or in the bookmarks toolbar)?
It may be not specific to search engines but be a more generic issue.

Yep. Looks like a general drag problem on Retina.
Flags: needinfo?(mozilla)
Component: Preferences → General
Seems a retina issue or OS integration issue
needinfo from Mike Conley and Wayne Mery on this if they have any insights
Flags: needinfo?(vseerror)
Flags: needinfo?(mconley)

Comment 10

2 years ago
The retina issues I've triaged have been graphics related. I'm not sure that's the case here, but CC ashughes who may know
Flags: needinfo?(vseerror) → needinfo?(anthony.s.hughes)

Updated

2 years ago
Component: General → Untriaged
Product: Firefox → Core
I'm afraid I don't have any insight here.
Flags: needinfo?(mconley)
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #10)
> The retina issues I've triaged have been graphics related. I'm not sure
> that's the case here, but CC ashughes who may know

I'm not certain it's a graphics issue unless :mkaply can provide a regression window pointing this to a graphics-related regression. For what it's worth I cannot reproduce this issue with Nightly on my system: MacBook Pro (Retina, 13-inch, Late 2013) running MacOS 10.11.5 Beta (15F31a).
Flags: needinfo?(anthony.s.hughes)
(Reporter)

Comment 13

2 years ago
> I'm not certain it's a graphics issue unless :mkaply can provide a regression window pointing this to a graphics-related regression. For what it's worth I cannot reproduce this issue with Nightly on my system: MacBook Pro (Retina, 13-inch, Late 2013) running MacOS 10.11.5 Beta (15F31a).

It happens on Firefox 38, so I don't think it is a regression. Given that you don't see it, maybe it's a Mac OS X bug? I'm running 10.11.4
Confirming: The mouse pointer does not change when dragging/moving the search engines.
Windows 10 - mouse pointer changes
Ubuntu 12.04 - mouse pointer changes
Mac 10.11 - mouse pointer does not change
Version  49.0a1
Build ID  20160505030327
User Agent  Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:49.0) Gecko/20100101 Firefox/49.0
Performed MozRegression 38-49 so I can confirm indeed it appears this has always been.
need info me if further investigation/assistance is needed.
Setting this to New CORE: Event Handling;
Component: Untriaged → Event Handling
Only retina versions on mac 10.11 seem to be affected. I'm using nightly on 10.11 on a non-retina mac and I'm not affected.
smaug, any thoughts?
Flags: needinfo?(bugs)
Whiteboard: btpp-followup-2016-05-13
No idea. mstange might know, given that this is some very OSX specific issue.
Flags: needinfo?(bugs) → needinfo?(mstange)
This might be bug 933302.
Flags: needinfo?(mstange)
(Reporter)

Comment 19

2 years ago
Technical bug titles don't make for good searches :)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 933302

Updated

a year ago
Depends on: 933302

Updated

a year ago
No longer depends on: 933302
You need to log in before you can comment on or make changes to this bug.