[GTK3] Slim black or white border around UI elements in Gnome/GTK 3.20

RESOLVED DUPLICATE of bug 1266914

Status

()

Core
Widget: Gtk
RESOLVED DUPLICATE of bug 1266914
2 years ago
2 years ago

People

(Reporter: Clément Lefèvre, Unassigned)

Tracking

({nightly-community})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mozfr-community])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8747450 [details]
GTK3 and white borders on dark theme.png

Using Archlinux, since the update to Gnome/GTK 3.20, a slim border have appeared around couple of elements in the UI. It is especially visible with dark themed Gnome around URL/search field, around the sandwich menu when it's open, between the webpage content and the top UI and so on as this appears in white.

See the joined screenshot. One noticeable side-effect is the little separation beween the black scrollbar zone and the UI.

Is this a wished behavior?

Reproduced on both latest nightly and current stable on Archlinux with last Gnome and GTK update.
(Reporter)

Updated

2 years ago
Blocks: 627699
Depends on: 1234158
See Also: → bug 1266914
(Reporter)

Updated

2 years ago
Whiteboard: [mozfr-community]
(Reporter)

Comment 1

2 years ago
The problem is actually the same with light-themed Gnome 3 and GTK 3.20, but slim borders are black instead of white.
Summary: [GTK3] White slim border around UI elements in Gnome/GTK 3.20 → [GTK3] Slim black or white border around UI elements in Gnome/GTK 3.20
Whiteboard: [mozfr-community] → [mozfr-community][nightly-community]
I think this is the same issue as bug 1266914.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1266914
See Also: bug 1266914
(Reporter)

Updated

2 years ago
Keywords: nightly-community
Whiteboard: [mozfr-community][nightly-community] → [mozfr-community]
You need to log in before you can comment on or make changes to this bug.