suggestion for HTML links opening new tab

VERIFIED DUPLICATE of bug 105409

Status

()

Core
DOM: Core & HTML
--
enhancement
VERIFIED DUPLICATE of bug 105409
16 years ago
9 years ago

People

(Reporter: cooperg, Assigned: jst)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
(This might be better suited to the Tabbed Browsing component..?)

I would like to suggest a TARGET="_TAB" attribute for HTML's "A" tag.
This would, obviously, open a link in a new window when clicked, rather
than a new window (using "_blank") or the same window (default).
 
For compatibility with other browsers or older Moz browsers 
a suggestion for usage might be to double up the "_tab" with,
for example, "_blank", like so:

[a href="whatever.html" target="_tab" target="_blank"]

(I used brackets rather than greater/lesser-thans in case this form allows HTML code)

Then give _tab precedence over _blank. If used without the
_blank, the target would be ignored.

Comment 1

16 years ago
dup of 105409
  [rfe] window.openTab() and <a href="url" target="_tab">

*** This bug has been marked as a duplicate of 105409 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
VERIFIED DUPLICATE.

Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: stummala → general
You need to log in before you can comment on or make changes to this bug.