Closed Bug 1269341 Opened 5 years ago Closed 4 years ago

tabs.query() disallows searching for extension's pages

Categories

(WebExtensions :: Untriaged, defect, P3)

defect

Tracking

(firefox49 affected)

RESOLVED DUPLICATE of bug 1271354
mozilla49
Tracking Status
firefox49 --- affected

People

(Reporter: ecfbugzilla, Assigned: kmag)

References

(Blocks 1 open bug)

Details

(Whiteboard: triaged)

Attachments

(1 file)

544 bytes, application/x-xpinstall
Details
Attached file Minimal test extension
Steps to reproduce:

1. Download attached extension.
2. Go to about:config and set xpinstall.signatures.required to false.
3. Open Add-ons Manager and install the extension from file.
4. Press Ctrl-Shift-J (Cmd-Shift-J on OS X) to open the Browser Console.

Expected results:

No error messages, the extension successfully called tabs.query() for one of its own URLs - as happening in Chrome.

Actual results:

Error message:

> Invalid match pattern: 'moz-extension://ab3bef6f-8307-7f4a-a92f-ffdaef522d41/foo.html'

The code causing this is the following:

  chrome.tabs.query({
    url: chrome.runtime.getURL("foo.html")
  });
Assignee: nobody → kmaglione+bmo
Priority: -- → P3
Whiteboard: triaged
Target Milestone: --- → mozilla49
This is the same as bug 1271354, the problem is MatchPattern doesn't allow/include the moz-extension scheme.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1271354
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.