Closed Bug 1269565 Opened 3 years ago Closed 3 years ago

Windows debug reftest-noaccel e10s perma-asserts on Ash (Assertion failure: !mUser.IsInitialized(), at gfx/config/gfxFeature.cpp:171)

Categories

(Core :: Graphics, defect, critical)

Unspecified
Windows
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla49
Tracking Status
e10s ? ---
firefox47 --- unaffected
firefox48 --- unaffected
firefox49 --- fixed

People

(Reporter: RyanVM, Assigned: dvander)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, crash, Whiteboard: [e10s-orangeblockers])

Attachments

(1 file)

https://treeherder.mozilla.org/logviewer.html#?job_id=172890&repo=ash

15:37:25     INFO -  REFTEST INFO | Running with e10s: True
15:37:26     INFO -  ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to c:\users\cltbld~1.t-w\appdata\local\temp\tmp_kcrrs.mozrunner\runreftest_leaks.log
15:37:26     INFO -  [3500] WARNING: XPCOM objects created/destroyed from static ctor/dtor: file c:/builds/moz2_slave/ash-w64-d-00000000000000000000/build/src/xpcom/base/nsTraceRefcnt.cpp, line 174
15:37:26     INFO -  [3500] WARNING: XPCOM objects created/destroyed from static ctor/dtor: file c:/builds/moz2_slave/ash-w64-d-00000000000000000000/build/src/xpcom/base/nsTraceRefcnt.cpp, line 174
15:37:26     INFO -  [3500] WARNING: Failed to load startupcache file correctly, removing!: file c:/builds/moz2_slave/ash-w64-d-00000000000000000000/build/src/startupcache/StartupCache.cpp, line 228
15:37:26     INFO -  [3500] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file c:/builds/moz2_slave/ash-w64-d-00000000000000000000/build/src/xpcom/base/nsSystemInfo.cpp, line 112
15:37:26     INFO -  [3500] WARNING: CheckLinkStatus called on main thread! No check performed. Assuming link is up, status is unknown.: file c:/builds/moz2_slave/ash-w64-d-00000000000000000000/build/src/netwerk/system/win32/nsNotifyAddrListener.cpp, line 558
15:37:26     INFO -  [3500] WARNING: This method is lossy. Use GetCanonicalPath !: file c:/builds/moz2_slave/ash-w64-d-00000000000000000000/build/src/xpcom/io/nsLocalFileWin.cpp, line 3457
15:37:29     INFO -  ++DOCSHELL 0000007825561800 == 1 [pid = 3500] [id = 1]
15:37:29     INFO -  ++DOMWINDOW == 1 (000000783669A800) [pid = 3500] [serial = 1] [outer = 0000000000000000]
15:37:29     INFO -  [3500] WARNING: No inner window available!: file c:/builds/moz2_slave/ash-w64-d-00000000000000000000/build/src/dom/base/nsGlobalWindow.cpp, line 9856
15:37:29     INFO -  ++DOMWINDOW == 2 (000000783669B800) [pid = 3500] [serial = 2] [outer = 000000783669A800]
15:37:29     INFO -  Assertion failure: !mUser.IsInitialized(), at c:/builds/moz2_slave/ash-w64-d-00000000000000000000/build/src/gfx/config/gfxFeature.cpp:171
15:37:43     INFO -  #01: gfxWindowsPlatform::InitializeDevices() [gfx/thebes/gfxWindowsPlatform.cpp:2304]
15:37:43     INFO -  #02: gfxWindowsPlatform::InitAcceleration() [gfx/thebes/gfxWindowsPlatform.cpp:419]
15:37:43     INFO -  #03: gfxPlatform::Init() [gfx/thebes/gfxPlatform.cpp:667]
15:37:43     INFO -  #04: gfxPlatform::GetPlatform() [gfx/thebes/gfxPlatform.cpp:514]
15:37:43     INFO -  #05: mozilla::widget::GfxInfo::GetD2DEnabled(bool *) [widget/windows/GfxInfo.cpp:51]
15:37:43     INFO -  #06: XPTC__InvokebyIndex [xpcom/reflect/xptcall/md/win32/xptcinvoke_asm_x86_64.asm:99]
15:37:43     INFO -  #07: CallMethodHelper::Call() [js/xpconnect/src/XPCWrappedNative.cpp:1402]
15:37:43     INFO -  #08: XPCWrappedNative::CallMethod(XPCCallContext &,XPCWrappedNative::CallMode) [js/xpconnect/src/XPCWrappedNative.cpp:1367]
15:37:43     INFO -  #09: XPC_WN_GetterSetter(JSContext *,unsigned int,JS::Value *) [js/xpconnect/src/XPCWrappedNativeJSOps.cpp:1164]
15:37:43     INFO -  #10: js::CallJSNative(JSContext *,bool (*)(JSContext *,unsigned int,JS::Value *),JS::CallArgs const &) [js/src/jscntxtinlines.h:235]
15:37:43     INFO -  #11: js::InternalCallOrConstruct(JSContext *,JS::CallArgs const &,js::MaybeConstruct) [js/src/vm/Interpreter.cpp:480]
15:37:43     INFO -  #12: js::CallGetter(JSContext *,JS::Handle<JS::Value>,JS::Handle<JS::Value>,JS::MutableHandle<JS::Value>) [js/src/vm/Interpreter.cpp:656]
15:37:43     INFO -  #13: CallGetter [js/src/vm/NativeObject.cpp:1743]
15:37:43     INFO -  #14: GetExistingProperty<1> [js/src/vm/NativeObject.cpp:1791]
15:37:43     INFO -  #15: NativeGetPropertyInline<1> [js/src/vm/NativeObject.cpp:2010]
15:37:43     INFO -  #16: js::NativeGetProperty(JSContext *,JS::Handle<js::NativeObject *>,JS::Handle<JS::Value>,JS::Handle<jsid>,JS::MutableHandle<JS::Value>) [js/src/vm/NativeObject.cpp:2045]
15:37:43     INFO -  #17: js::GetProperty(JSContext *,JS::Handle<JSObject *>,JS::Handle<JS::Value>,JS::Handle<jsid>,JS::MutableHandle<JS::Value>) [js/src/vm/NativeObject.h:1509]
15:37:43     INFO -  #18: js::GetProperty(JSContext *,JS::Handle<JSObject *>,JS::Handle<JSObject *>,JS::Handle<jsid>,JS::MutableHandle<JS::Value>) [js/src/jsobj.h:832]
15:37:43     INFO -  #19: js::GetObjectElementOperation [js/src/vm/Interpreter-inl.h:453]
15:37:43     INFO -  #20: js::GetElementOperation [js/src/vm/Interpreter-inl.h:558]
15:37:43     INFO -  #21: Interpret [js/src/vm/Interpreter.cpp:2669]
15:37:43     INFO -  #22: js::RunScript(JSContext *,js::RunState &) [js/src/vm/Interpreter.cpp:426]
15:37:43     INFO -  #23: js::InternalCallOrConstruct(JSContext *,JS::CallArgs const &,js::MaybeConstruct) [js/src/vm/Interpreter.cpp:498]
15:37:43     INFO -  #24: js::CallGetter(JSContext *,JS::Handle<JS::Value>,JS::Handle<JS::Value>,JS::MutableHandle<JS::Value>) [js/src/vm/Interpreter.cpp:656]
15:37:43     INFO -  #25: CallGetter [js/src/vm/NativeObject.cpp:1743]
15:37:43     INFO -  #26: GetExistingProperty<1> [js/src/vm/NativeObject.cpp:1791]
15:37:43     INFO -  #27: NativeGetPropertyInline<1> [js/src/vm/NativeObject.cpp:2010]
15:37:43     INFO -  #28: js::NativeGetProperty(JSContext *,JS::Handle<js::NativeObject *>,JS::Handle<JS::Value>,JS::Handle<jsid>,JS::MutableHandle<JS::Value>) [js/src/vm/NativeObject.cpp:2045]
15:37:43     INFO -  #29: js::GetProperty(JSContext *,JS::Handle<JSObject *>,JS::Handle<JS::Value>,JS::Handle<jsid>,JS::MutableHandle<JS::Value>) [js/src/vm/NativeObject.h:1509]
15:37:43     INFO -  #30: js::DirectProxyHandler::get(JSContext *,JS::Handle<JSObject *>,JS::Handle<JS::Value>,JS::Handle<jsid>,JS::MutableHandle<JS::Value>) [js/src/proxy/DirectProxyHandler.cpp:250]
15:37:43     INFO -  #31: js::CrossCompartmentWrapper::get(JSContext *,JS::Handle<JSObject *>,JS::Handle<JS::Value>,JS::Handle<jsid>,JS::MutableHandle<JS::Value>) [js/src/proxy/CrossCompartmentWrapper.cpp:185]
15:37:43     INFO -  #32: js::Proxy::get(JSContext *,JS::Handle<JSObject *>,JS::Handle<JS::Value>,JS::Handle<jsid>,JS::MutableHandle<JS::Value>) [js/src/proxy/Proxy.cpp:309]
15:37:43     INFO -  #33: js::proxy_GetProperty(JSContext *,JS::Handle<JSObject *>,JS::Handle<JS::Value>,JS::Handle<jsid>,JS::MutableHandle<JS::Value>) [js/src/proxy/Proxy.cpp:582]
15:37:43     INFO -  #34: js::GetProperty(JSContext *,JS::Handle<JSObject *>,JS::Handle<JS::Value>,JS::Handle<jsid>,JS::MutableHandle<JS::Value>) [js/src/vm/NativeObject.h:1509]
15:37:43     INFO -  #35: js::GetProperty(JSContext *,JS::Handle<JSObject *>,JS::Handle<JS::Value>,js::PropertyName *,JS::MutableHandle<JS::Value>) [js/src/jsobj.h:824]
15:37:43     INFO -  #36: js::GetProperty(JSContext *,JS::Handle<JS::Value>,JS::Handle<js::PropertyName *>,JS::MutableHandle<JS::Value>) [js/src/vm/Interpreter.cpp:4109]
15:37:43     INFO -  #37: GetPropertyOperation [js/src/vm/Interpreter.cpp:217]
15:37:43     INFO -  #38: Interpret [js/src/vm/Interpreter.cpp:2548]
15:37:43     INFO -  #39: js::RunScript(JSContext *,js::RunState &) [js/src/vm/Interpreter.cpp:426]
15:37:43     INFO -  #40: js::InternalCallOrConstruct(JSContext *,JS::CallArgs const &,js::MaybeConstruct) [js/src/vm/Interpreter.cpp:498]
15:37:43     INFO -  #41: js::Call(JSContext *,JS::Handle<JS::Value>,JS::Handle<JS::Value>,js::AnyInvokeArgs const &,JS::MutableHandle<JS::Value>) [js/src/vm/Interpreter.cpp:544]
15:37:43     INFO -  #42: JS_CallFunctionValue(JSContext *,JS::Handle<JSObject *>,JS::Handle<JS::Value>,JS::HandleValueArray const &,JS::MutableHandle<JS::Value>) [js/src/jsapi.cpp:2864]
15:37:43     INFO -  #43: nsXPCWrappedJSClass::CallMethod(nsXPCWrappedJS *,unsigned short,XPTMethodDescriptor const *,nsXPTCMiniVariant *) [js/xpconnect/src/XPCWrappedJSClass.cpp:1238]
15:37:43     INFO -  #44: nsXPCWrappedJS::CallMethod(unsigned short,XPTMethodDescriptor const *,nsXPTCMiniVariant *) [js/xpconnect/src/XPCWrappedJS.cpp:603]
15:37:43     INFO -  #45: PrepareAndDispatch [xpcom/reflect/xptcall/md/win32/xptcstubs_x86_64.cpp:174]
15:37:43     INFO -  #46: SharedStub [xpcom/reflect/xptcall/md/win32/xptcstubs_asm_x86_64.asm:61]
15:37:43     INFO -  #47: NS_CreateServicesFromCategory(char const *,nsISupports *,char const *,char16_t const *) [xpcom/components/nsCategoryManager.cpp:818]
15:37:43     INFO -  #48: nsXREDirProvider::DoStartup() [toolkit/xre/nsXREDirProvider.cpp:958]
15:37:43     INFO -  #49: XREMain::XRE_mainRun() [toolkit/xre/nsAppRunner.cpp:4217]
15:37:43     INFO -  #50: XREMain::XRE_main(int,char * * const,nsXREAppData const *) [toolkit/xre/nsAppRunner.cpp:4451]
15:37:43     INFO -  #51: XRE_main [toolkit/xre/nsAppRunner.cpp:4559]
15:37:43     INFO -  #52: do_main [browser/app/nsBrowserApp.cpp:220]
15:37:43     INFO -  #53: NS_internal_main(int,char * *,char * *) [browser/app/nsBrowserApp.cpp:360]
15:37:43     INFO -  #54: wmain [toolkit/xre/nsWindowsWMain.cpp:138]
15:37:43     INFO -  #55: __scrt_common_main_seh [f:/dd/vctools/crt/vcstartup/src/startup/exe_common.inl:255]
15:37:43     INFO -  #56: KERNEL32.DLL + 0x167e
15:37:43     INFO -  #57: ntdll.dll + 0x1c3f1
Flags: needinfo?(dvander)
Attached patch patchSplinter Review
Well now we know these asserts work.

When hardware compositing is disabled, we forcefully disable D2D/D3D11. The problem is we are deciding this twice for D2D, and the gfxConfig state machine doesn't let you set a default value twice.

This patch removes the offending D2D line, and moves the D3D11 one into InitializeD3D11Config where it belongs.
Assignee: nobody → dvander
Status: NEW → ASSIGNED
Flags: needinfo?(dvander)
Attachment #8748067 - Flags: review?(milan)
Attachment #8748067 - Flags: review?(milan) → review+
https://hg.mozilla.org/mozilla-central/rev/d90072777443
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
You need to log in before you can comment on or make changes to this bug.