Clear private data on exit does not clear browsing history.

RESOLVED DUPLICATE of bug 1266594

Status

()

Firefox for Android
Settings and Preferences
RESOLVED DUPLICATE of bug 1266594
2 years ago
2 years ago

People

(Reporter: Seburo, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160413135225

Steps to reproduce:

In Firefox for Android Nightly 49.0a1 (2016-05-03):

1. Menu>Settings>Privacy>Clear private data on exit
2. (Selected all data types to clear)> Set
3. (Browse web, build up history)
4. Menu> Exit


Actual results:

Firefox for Android Nightly closes but on opening again, web history still held in browser.  This is evidenced by web content from browsing in tiles on the Top Sites screen (with web pages listed below), as well as web pages visited listed in History.


Expected results:

On selecting Menu>Exit, browser should close and on reopening, past web content (as selected) should have been removed.

(Web history could be successfully cleared by selecting "Clear Browsing History" on the History tab on the home screen as well as "Clear private data" in the Settings menu which also works as expected.  Bug only relates to failure to clear history when selecting "Clear private data on exit".)
Most likely dup of:

   Bug 1269159 - Clear private data on exit is incomplete
   Bug 1266594 - "Clear private data on exit" should work

Which are both the same root cause.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1266594
You need to log in before you can comment on or make changes to this bug.