Redesign the download status information for each item in downloads panel

RESOLVED DUPLICATE of bug 1282662

Status

()

Firefox
Downloads Panel
RESOLVED DUPLICATE of bug 1282662
a year ago
6 months ago

People

(Reporter: seanlee, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CHE-MVP])

(Reporter)

Description

a year ago
In the new UX design, we have to consider the following status change:
Starting
Downloading
Complete
Pause
Cancelled
Failed
Deleted

and this will also affect to Click/Hover behavior and description.
(Reporter)

Updated

11 months ago
Blocks: 1282662
(Reporter)

Updated

11 months ago
Blocks: 1282664
(Reporter)

Comment 1

11 months ago
Based on UX spec, Bryant helps to come out the major changes for the new design in the normal case:

* Starting/Downloading
  - Introducing Starting 
  - String: Add download speed info
* Completed
  - String: remove all string
* Cancelled
  - String: keep only status info 
* Paused
  - String: Same as original
* Deleted
  - String: add status, remove download size 
  - Thread : grey out
* Failed
  - String: keep only status info and reason
* Malware
  - String: add alert info
* Uncommon Download
  - String: add alert info
* Unwanted Download
  - String: add alert info

Updated

10 months ago
Whiteboard: [CHE-MVP]
(Reporter)

Updated

8 months ago
Blocks: 1307064
(Reporter)

Updated

6 months ago
No longer blocks: 1282664

Updated

6 months ago
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1282662

Comment 3

6 months ago
Bug 1282662 will implement both normal and hover cases.
You need to log in before you can comment on or make changes to this bug.