Closed Bug 127030 Opened 18 years ago Closed 10 years ago

"Outline View" for accessibility (as sidebar?)

Categories

(SeaMonkey :: Sidebar, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: BenB, Unassigned)

References

()

Details

(Keywords: access, helpwanted)

<http://www.w3.org/TR/2001/CR-UAAG10-20010912/guidelines#tech-provide-outline-view>

Would be easy and cleanly to implement header/caption listings via a sidebar
panel. We could use Eric's Link toolbar
<http://segment7.net/mozilla/linktoolbar/> as codebase. I even thought of
writing it (listing and linking to <hN>s using nested <ul>s), but never got ot it.
Keywords: access
I'm not sure sidebar will have enough width for the information we need to provide.
Changing summary.
Summary: Sidebar panel: "Outline View" (accessability) → "Outline View" for accessibility (as sidebar?)
-> Ben Buksch
Assignee: sgehani → ben.bucksch
Eric, want to take this?
Assignee: ben.bucksch → nobody
Keywords: helpwanted
Target Milestone: --- → Future
Accepting bug.

It seems like http://segment7.net/mozilla/links/links.html is a better start,
although it isn't OO'd yet.  I've made some changes to it to make it work again,
but so far only for the first tab.  It would be trivially easy to rework that
codebase into pulling out h?, caption, etc.  Now I'll have to scare out all the
bitrot and make ti purdy
Status: NEW → ASSIGNED
> Accepting bug.

You need to reassign to yourself first. Doing that.

> It seems like http://segment7.net/mozilla/links/links.html is a better start,

Yes, that's what I meant.

Assignee: nobody → drbrain-bugzilla
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
It seems that outlining is a "plus" both for editing and browsing...
Should browser and and editor teams collabrate on this issue?

Please see
http://bugzilla.mozilla.org/show_bug.cgi?id=138162
Another outline that might be helpful is the DOM inspector's outliner/tree 
view.
Product: Browser → Seamonkey
Assignee: drbrain-bugzilla → nobody
Status: ASSIGNED → NEW
QA Contact: sujay → sidebar
Target Milestone: Future → ---
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
Status: UNCONFIRMED → NEW
The SeaMonkey team will no create that feature, but if you want to have it, please create a SeaMonkey 2 add-on for it. If that is widely adopted (and only then), we could perhaps talk about adding it to our main code, but in case that's not happening, I'm seeing this as a WONTFIX.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.