Closed Bug 1270415 Opened 4 years ago Closed 4 years ago

Pop-up possible protocol handlers or request OS to handle it, while click a protocol link has no default handler

Categories

(Firefox :: File Handling, defect)

defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: edenchuang, Assigned: edenchuang)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

When user clicks a protocol link has no default handler, we need to pop-up a possible handler list dialog for user, otherwise, directly request OS to open the protocol link.
The possible handlers are the registered web apps, add-ons, plugins or OS preferred native app.
Blocks: 1270403
Assignee: nobody → echuang
Since the new content handling flow spec does not lock down, suspend this bug until the spec is confirmed.
Now spec is locked down. The following flow will be implemented

https://mozilla.invisionapp.com/share/A96ZY4ID8#/screens/162255311
1. If user has set a default handler, open the URL with the handler.
2. If registered handlers or OS default handler exist, popup "Launch Application" panel for user to choose the proper handler.
3. Otherwise, ask OS handle the URL directly.

The patch is ready for review. However, the spec is rollback to original design after London work week. UX team will do user research for the new design if we should improve the flow by this way. Once UX team decides to do, I will push patch into review process.
Bryant, this bug is waiting for spec lock down.

https://mozilla.invisionapp.com/share/A96ZY4ID8#/screens/162255311

Once the spec is finalized, please clean the NI flag to let me know the patch can be pushed into review process. Thanks.
Flags: needinfo?(bmao)
Whiteboard: [CHE-MVP]
This bug is shown in our Triage dashboard.
I would like to keep monitoring/NI because Bryant is working on it.
UX team finally decide to keep "Always Ask" option for handler control, this bug becomes invalid.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(bmao)
Resolution: --- → INVALID
Whiteboard: [CHE-MVP]
You need to log in before you can comment on or make changes to this bug.