test_buildapi.py's 'test_ingest_builds4h_jobs_1_missing_resultset' fails when run standalone, after bug 1234247

RESOLVED DUPLICATE of bug 1240809

Status

Tree Management
Treeherder: Docs & Development
P3
normal
RESOLVED DUPLICATE of bug 1240809
2 years ago
2 years ago

People

(Reporter: emorley, Unassigned)

Tracking

Details

Attachments

(1 attachment)

test_buildapi.py is currently passing when run as part of the whole test suite, or when all tests under tests/etl/ are run together, however fails when run on it's own.

ie:

PASSES... `py.test -x tests/etl/ -v`

FAILS... `py.test -x tests/etl/test_buildapi.py -v`

This only started happening after bug 1234247.

What's strange is that the verbose pytest output shows the test ordering (within test_buildapi.py) as the same in each of the above cases. The only difference is that in the passing case, test_bugzilla.py runs first - however it doesn't seem to do anything that should affect the later tests.

However bug 1191934 is soon going to remove the failing test, so may not be worth trying to figure out.

Full output...


PASSING:


vagrant ~/treeherder $ py.test -x tests/etl/ -v
============================================ test session starts =============================================

platform linux2 -- Python 2.7.11, pytest-2.9.0, py-1.4.31, pluggy-0.3.1 -- /home/vagrant/venv/bin/python
cachedir: .cache
django settings: tests.settings (from ini file)
rootdir: /home/vagrant/treeherder, inifile: pytest.ini
plugins: django-2.9.1
collected 207 items

tests/etl/test_bugzilla.py::test_bz_api_process PASSED
tests/etl/test_buildapi.py::test_ingest_pending_jobs PASSED
tests/etl/test_buildapi.py::test_ingest_running_jobs PASSED
tests/etl/test_buildapi.py::test_ingest_builds4h_jobs PASSED
tests/etl/test_buildapi.py::test_ingest_running_to_complete_job PASSED
tests/etl/test_buildapi.py::test_ingest_running_job_fields PASSED
tests/etl/test_buildapi.py::test_ingest_builds4h_jobs_1_missing_resultset PASSED
tests/etl/test_buildapi.py::test_ingest_builds4h_jobs_missing_branch PASSED
tests/etl/test_buildbot.py::test_buildername_translation[Android 2.2 Armv6 mozilla-inbound build-exp_result0] PASSED
...
tests/etl/test_pushlog.py::test_empty_json_pushes PASSED

======================================== 207 passed in 49.77 seconds =========================================



FAILING:

vagrant ~/treeherder $ py.test -x tests/etl/test_buildapi.py -v
============================================ test session starts =============================================

platform linux2 -- Python 2.7.11, pytest-2.9.0, py-1.4.31, pluggy-0.3.1 -- /home/vagrant/venv/bin/python
cachedir: .cache
django settings: tests.settings (from ini file)
rootdir: /home/vagrant/treeherder, inifile: pytest.ini
plugins: django-2.9.1
collected 7 items

tests/etl/test_buildapi.py::test_ingest_pending_jobs PASSED
tests/etl/test_buildapi.py::test_ingest_running_jobs PASSED
tests/etl/test_buildapi.py::test_ingest_builds4h_jobs PASSED
tests/etl/test_buildapi.py::test_ingest_running_to_complete_job PASSED
tests/etl/test_buildapi.py::test_ingest_running_job_fields PASSED
tests/etl/test_buildapi.py::test_ingest_builds4h_jobs_1_missing_resultset FAILED
Destroying test database for alias 'default'...
Created attachment 8749122 [details]
Full failure output
Summary: test_buildapi.py fails when run standalone, after bug 1234247 → test_buildapi.py's 'test_ingest_builds4h_jobs_1_missing_resultset' fails when run standalone, after bug 1234247
Bug 1240809 fixed this :-)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1240809
You need to log in before you can comment on or make changes to this bug.