Closed Bug 1270564 Opened 4 years ago Closed 4 years ago

Resizing the Synced Tabs sidebar shifts its contents

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 49
Tracking Status
firefox49 --- verified
firefox50 --- verified
firefox51 --- verified

People

(Reporter: rfeeley, Assigned: eoger)

Details

Attachments

(2 files, 1 obsolete file)

Attached image weird-shrinking.gif
STR
Be syncing at least device with a long name (iOS default)

ER
Resizing the sidebar should affect its contents like in history and bookmarks sidebar (meaning, not at all)

AR
Device name shifts over and twisty is cropped
Attached patch bug-1270564.patch (obsolete) — Splinter Review
This fix is OSX only since Windows seems to be doing something reasonable already (see : http://recordit.co/b5DRLc3R18), is that okay with you Ryan?
Flags: needinfo?(rfeeley)
Attachment #8749435 - Flags: review?(markh)
Attachment #8749435 - Flags: review?(markh) → review+
Screencast much appreciated. It still looks like there is some twisty-stranges going on – shrinking is better than cropping, but unless the other sidebars do this, I'd like to avoid that too.
Flags: needinfo?(rfeeley) → needinfo?(edouard.oger)
With this patch the problem is gone on all platforms.
Assignee: nobody → edouard.oger
Attachment #8749435 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Flags: needinfo?(edouard.oger)
Attachment #8750435 - Flags: review?(markh)
Comment on attachment 8750435 [details] [diff] [review]
bug-1270564.patch

Review of attachment 8750435 [details] [diff] [review]:
-----------------------------------------------------------------

Carrying r+ forward
Attachment #8750435 - Flags: review?(markh) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/fbcef8c33caa
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 49
Flags: qe-verify+
I managed to reproduce this issue on Firefox 48.0b1 and on Windows 10x64.
The issue is no longer reproducible on Firefox 51.0a1 (2016-08-25), Firefox 50.0a2 (2016-08-25), or on Firefox 49.0b6.
The tests were performed under Windows 10x64, Ubuntu 14.04x86 and under Mac OS X 10.11.1.
I am marking this issue Verified Fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
OS: Mac OS X → All
Hardware: x86 → All
You need to log in before you can comment on or make changes to this bug.