Closed Bug 1270649 Opened 4 years ago Closed 4 years ago

Rename mExceptionHasBeenRisen to mExceptionWasRaised

Categories

(Core :: DOM: Events, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla49
Tracking Status
firefox49 --- fixed

People

(Reporter: dbaron, Assigned: dbaron)

References

Details

(Whiteboard: btpp-active)

Attachments

(1 file)

risen is the past participle of rise; raised is the past participle of
raise, which is what is done to exceptions.

See:
https://en.wiktionary.org/wiki/rise#Verb
https://en.wiktionary.org/wiki/raise#Verb (definition 2, though not sure
  if the use for exceptions is from 2.3 or 2.5)

(I wonder if mExceptionRaised would be simpler, though.)

MozReview-Commit-ID: 8Ynup8aDcLT
Whiteboard: btpp-active
Comment on attachment 8749418 [details] [diff] [review]
Rename mExceptionHasBeenRisen to mExceptionHasBeenRaised

Hmm, shouldn't it then be
mExceptionWasRaised.
But you're the native English speaker, rs+
Attachment #8749418 - Flags: review?(bugs) → review+
Yes, mExceptionWasRaised is probably better.  (simple past rather than (present) perfect.)  I'll do that.
Summary: Rename mExceptionHasBeenRisen to mExceptionHasBeenRaised → Rename mExceptionHasBeenRisen to mExceptionWasRaised
https://hg.mozilla.org/mozilla-central/rev/730147bfebe3
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
You need to log in before you can comment on or make changes to this bug.