Closed Bug 1270787 Opened 6 years ago Closed 6 years ago

Add ability to handle user actions on tabs (click, mousedown, mouseup, mousemove, etc.)

Categories

(WebExtensions :: Untriaged, defect)

defect
Not set
normal

Tracking

(firefox49 affected)

RESOLVED DUPLICATE of bug 1246706
Tracking Status
firefox49 --- affected

People

(Reporter: yuki, Unassigned)

References

Details

This is a request for new `chrome.tabs.onXXXXX` API.

My addon "Multiple Tab Handler" provides ability to select(highlight) tabs by dragging on tabs, and shows a popup menu when the mouse button is released. In other words, dragging on tabs is treated as area-selection for icons on the desktop. After XUL is ended, something alternative is required to migrate my addon to WebExtensions.

And, the API should provide ability to cancel actions on tabs. It will allow addons to provide various custom actions, like Tab Mix Plus. In other words Tab Mix Plus will require this or similar API to be migrated.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1246706
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.