Wikipedia map template pushes points to one side

RESOLVED FIXED

Status

P3
normal
RESOLVED FIXED
3 years ago
2 days ago

People

(Reporter: fios, Assigned: adamopenweb)

Tracking

Firefox 46

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [country-all][sitewait])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8750110 [details]
Screenshot of problem.png

Scenario: 
1) Access a Wikipedia map template e.g. https://en.wikipedia.org/wiki/Template:Iraqi_insurgency_detailed_map
2) All the locator dots are squashed against the left side of the map (see screenshot)
This works ok (on Nightly) if you use desktop mode. The locator dots are positioned using percentage positioning (e.g. "position:absolute;top:13.161%;left:35.295%"), but in mobile mode (the default) they are positioned relative to the mobile viewport. Chrome does the same thing, so I think this is an evangelism issue.
Component: Graphics, Panning and Zooming → Mobile
Product: Firefox for Android → Tech Evangelism
Version: 46 Branch → Firefox 46
Thanks Kats.

Adam, can you report a bug on mobile wikipedia? https://phabricator.wikimedia.org/
Flags: needinfo?(astevenson)
Whiteboard: [country-all][contactready]
(Assignee)

Comment 3

3 years ago
Reported: https://phabricator.wikimedia.org/T135857
Assignee: nobody → astevenson
Status: NEW → ASSIGNED
Flags: needinfo?(astevenson)
Whiteboard: [country-all][contactready] → [country-all][sitewait]
Priority: -- → P3
The issue is no longer reproducible on Google Pixel (Android 8.1.0) - 1080 x 1920 pixels (~441 ppi pixel density) and Mozilla Firefox Nightly 63.

Closing as fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED
Component: Mobile → Mobile
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.