<plaintext> delimiter doesn't work as expected

RESOLVED FIXED in Future

Status

()

RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: greg, Assigned: harishd)

Tracking

({testcase})

Trunk
Future
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.0.3 (X11; Linux i586; U;) Gecko/20020211
BuildID:    2002021422

Problem is short:
write down such testing file:

<html>
<head><title>testing plaintext problem</title></head>
<body>
some text
<p comment="remove this for test">
<plaintext>
plaintext  lines
  of text data
</plaintext>
normal text below plaintext in the same paragraph
</p comment="remove this for test">
normal text below plaintext
<p>normal text in paragraph</p>
</body>
</html>

1. Problem is that text inside the same paragraph (<p>)
as <plaintext> after </plaintext> is also rendered using
font setting as for plaintext above !
almost as if it were INSIDE <plaintext> tag.

2. It can be even worse, because if You use <plaintext>
NOT iside paragraph <p> (remove items marked "remove for test")
all below content of html file will be rendered this way.

If sth. was not clear - contact me.
HTH


Reproducible: Always
Steps to Reproduce:
just use file content I wrote above
Parser.  We don't close out the <plaintext> properly...
Assignee: asa → harishd
Status: UNCONFIRMED → NEW
Component: Browser-General → Parser
Ever confirmed: true
QA Contact: doronr → moied
As a note, NS4 shows everything after the <plaintext>, going right through
</plaintext> and all the other block closures.....
(Assignee)

Comment 4

17 years ago
Not a high priority.

This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another 
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration. 

Target Milestone: --- → Future

Comment 5

16 years ago
Created attachment 124014 [details]
Testcase #2, as above but with "remove this for test" removed

Updated

16 years ago
Keywords: testcase
Summary: delimiter doesn't work as expected → <plaintext> delimiter doesn't work as expected
Depends on: 88987
<plaintext> support has been removed (in bug 88987), so marking fixed (not an
issue anymore).
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.