Intermittent testAccessibleCarets | testAccessibleCarets.js - [ false === true ] There should now be paste-able text in the clipboard. - See following stack:

RESOLVED FIXED in Firefox 51

Status

()

Firefox for Android
Testing
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Tomcat, Assigned: gbrown)

Tracking

({intermittent-failure})

unspecified
Firefox 51
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox51 fixed)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
https://treeherder.mozilla.org/logviewer.html#?job_id=27491579&repo=mozilla-inbound#L3595


 05:36:13 WARNING - TEST-UNEXPECTED-FAIL | testAccessibleCarets | testAccessibleCarets.js - [ false === true ] There should now be paste-able text in the clipboard. - See following stack:

Comment 1

2 years ago
61 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 36
* fx-team: 18
* mozilla-central: 6
* try: 1

Platform breakdown:
* android-4-3-armv7-api15: 61

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1271264&startday=2016-05-10&endday=2016-05-16&tree=all

Comment 2

2 years ago
56 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 39
* fx-team: 10
* mozilla-central: 5
* try: 2

Platform breakdown:
* android-4-3-armv7-api15: 56

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1271264&startday=2016-05-16&endday=2016-05-22&tree=all

Comment 3

2 years ago
16 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 11
* fx-team: 3
* mozilla-central: 2

Platform breakdown:
* android-4-3-armv7-api15: 16

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1271264&startday=2016-05-24&endday=2016-05-24&tree=all

Comment 4

2 years ago
49 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 32
* fx-team: 9
* mozilla-central: 8

Platform breakdown:
* android-4-3-armv7-api15: 49

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1271264&startday=2016-05-23&endday=2016-05-29&tree=all

Comment 5

2 years ago
54 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 39
* fx-team: 9
* mozilla-central: 5
* try: 1

Platform breakdown:
* android-4-3-armv7-api15: 54

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1271264&startday=2016-05-30&endday=2016-06-05&tree=all

Comment 6

2 years ago
74 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 54
* fx-team: 14
* mozilla-central: 4
* try: 2

Platform breakdown:
* android-4-3-armv7-api15: 73
* windows7-32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1271264&startday=2016-06-06&endday=2016-06-12&tree=all

Comment 7

2 years ago
25 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 15
* fx-team: 6
* mozilla-central: 4

Platform breakdown:
* android-4-3-armv7-api15: 25

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1271264&startday=2016-06-13&endday=2016-06-19&tree=all

Comment 8

2 years ago
45 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 31
* try: 7
* fx-team: 3
* mozilla-central: 2
* autoland: 2

Platform breakdown:
* android-4-3-armv7-api15: 45

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1271264&startday=2016-06-20&endday=2016-06-26&tree=all

Comment 9

2 years ago
15 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 11
* mozilla-central: 3
* fx-team: 1

Platform breakdown:
* android-4-3-armv7-api15: 15

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1271264&startday=2016-06-28&endday=2016-06-28&tree=all

Comment 10

2 years ago
31 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 19
* autoland: 5
* mozilla-central: 4
* fx-team: 3

Platform breakdown:
* android-4-3-armv7-api15: 31

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1271264&startday=2016-06-27&endday=2016-07-03&tree=all

Comment 11

2 years ago
8 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 4
* fx-team: 3
* mozilla-central: 1

Platform breakdown:
* android-4-3-armv7-api15: 8

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1271264&startday=2016-07-04&endday=2016-07-10&tree=all

Comment 12

2 years ago
15 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 7
* autoland: 6
* fx-team: 2

Platform breakdown:
* android-4-3-armv7-api15: 15

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1271264&startday=2016-07-11&endday=2016-07-17&tree=all
In other tests, like https://dxr.mozilla.org/mozilla-central/rev/2ea3d51ba1bb9f5c3b6921c43ea63f70b4fdf5d2/editor/libeditor/tests/test_CF_HTML_clipboard.html#47, I see hasDataMatchingFlavors() called in a polling loop; would that be appropriate here?
Flags: needinfo?(markcapella)
Yah, my last dangling thread :-/

I dug down the clipboard codepaths briefly here, and stopped with the belief we're losing an async race, and probably need a promise callback. 

Does that help? (I'm time-constrained atm, or I'd look closer).
Flags: needinfo?(markcapella)

Comment 15

2 years ago
24 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 10
* autoland: 7
* fx-team: 5
* mozilla-central: 2

Platform breakdown:
* android-4-3-armv7-api15: 24

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1271264&startday=2016-07-25&endday=2016-07-31&tree=all

Comment 16

2 years ago
68 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 35
* autoland: 18
* fx-team: 10
* mozilla-central: 5

Platform breakdown:
* android-4-3-armv7-api15: 67
* android-api-15-gradle: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1271264&startday=2016-08-01&endday=2016-08-07&tree=all

Comment 17

2 years ago
52 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 25
* mozilla-inbound: 20
* mozilla-central: 6
* fx-team: 1

Platform breakdown:
* android-4-3-armv7-api15: 46
* android-api-15-gradle: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1271264&startday=2016-08-08&endday=2016-08-14&tree=all

Comment 18

2 years ago
45 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 19
* autoland: 18
* mozilla-central: 3
* fx-team: 3
* try: 2

Platform breakdown:
* android-4-3-armv7-api15: 42
* android-api-15-gradle: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1271264&startday=2016-08-15&endday=2016-08-21&tree=all
Assignee: nobody → gbrown
Created attachment 8784415 [details] [diff] [review]
populate clipboard earlier

This is speculative: I don't know the cause of the failure. I see other tests that either retry until hasDataMatchingFlavors() succeeds, or ensure that time passes between populating the clipboard and calling hasDataMatchingFlavors().

For this test, moving the clipboard population before loading the test page ought to provide ample opportunity for whatever we are waiting for. On try, I don't see any failures with this change: https://treeherder.mozilla.org/#/jobs?repo=try&revision=f1523639abd1 (there are existing frequent failures in testUnifiedTelemetryClientId).
Attachment #8784415 - Flags: review?(markcapella)
Comment on attachment 8784415 [details] [diff] [review]
populate clipboard earlier

Review of attachment 8784415 [details] [diff] [review]:
-----------------------------------------------------------------

Seems fragile, but it should suffice for test/support code.

on quick read ... relevant code where Clipboard background task |setTask()| goes async in parallel to Gecko [0] ... the |getTask()| version seems to trick out a sync-like positive return from the background task via SynchronousQueue [1] 

Can we enhance that in a followup?

[0] https://dxr.mozilla.org/mozilla-central/source/mobile/android/geckoview/src/main/java/org/mozilla/gecko/util/Clipboard.java#62
[1] https://dxr.mozilla.org/mozilla-central/source/mobile/android/geckoview/src/main/java/org/mozilla/gecko/util/Clipboard.java#35
Attachment #8784415 - Flags: review?(s.kaspari)
Attachment #8784415 - Flags: review?(markcapella)
Attachment #8784415 - Flags: feedback+
Attachment #8784415 - Flags: review?(s.kaspari) → review+
(In reply to Mark Capella [:capella] from comment #20)
> Can we enhance that in a followup?

I will file a bug but likely won't pursue it if the test becomes stable.

Comment 22

2 years ago
15 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 10
* autoland: 4
* mozilla-central: 1

Platform breakdown:
* android-4-3-armv7-api15: 13
* android-api-15-gradle: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1271264&startday=2016-08-25&endday=2016-08-25&tree=all

Comment 23

2 years ago
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0b26c3764c4c
Populate clipboard earlier to avoid intermittent failure in testAccessibleCarets; r=sebastian
See Also: → bug 1298506

Comment 24

2 years ago
20 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 11
* autoland: 8
* mozilla-central: 1

Platform breakdown:
* android-4-3-armv7-api15: 19
* android-api-15-gradle: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1271264&startday=2016-08-26&endday=2016-08-26&tree=all

Comment 25

2 years ago
71 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 35
* autoland: 28
* mozilla-central: 3
* fx-team: 3
* try: 1
* oak: 1

Platform breakdown:
* android-4-3-armv7-api15: 64
* android-api-15-gradle: 7

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1271264&startday=2016-08-22&endday=2016-08-28&tree=all

Comment 26

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/0b26c3764c4c
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox51: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
You need to log in before you can comment on or make changes to this bug.