X clipboard does not work with dual screen setup

RESOLVED INVALID

Status

()

Core
Widget: Gtk
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: Tomi Leppikangas, Unassigned)

Tracking

46 Branch
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
After 46.0.1 update X copy/paste from firefox to xterm does not work. Copy/paste works if firefox and xterm are in same X screen, but when xterm is in separate screen, paste does not work.

I think this is caused by switching to gtk3, Bug 1186003

I tryed to run with GDK_DEBUG=events, i can see debug message when trying to paste to xterm, but nothing is pasted:
Gdk-Message: selection request: window: 39845943


My setup: Dual monitros with separate X screens  xterm on :0.0 and firefox on :0.1

Commands to start test setup:
xterm -display :0.1 -e "~/firefox/firefox"&
xterm&


dpyinfo:
name of display:    :0
version number:    11.0
vendor string:    Fedora Project
vendor release number:    11704000
.........
default screen number:    0
number of screens:    2

screen #0:
  dimensions:    1920x1080 pixels (483x272 millimeters)
  resolution:    101x101 dots per inch
  depths (7):    24, 1, 4, 8, 15, 16, 32
  root window id:    0x4f5
.....

screen #1:
  dimensions:    1024x1280 pixels (305x391 millimeters)
  resolution:    85x83 dots per inch
  depths (7):    24, 1, 4, 8, 15, 16, 32
  root window id:    0x4f7
......

Updated

2 years ago
Component: General → Widget: Gtk
Product: Firefox → Core
Summary: x clipboard does not work with dual screen setup → X clipboard does not work with dual screen setup
Blocks: 627699
Can you try with the gtk3-widget-factory program, please?
That may be in a gtk-3-examples package.
That would indicate whether this is a bug in GTK or may be in the way Gecko is using it.
(Reporter)

Comment 2

2 years ago
I tested gtk3-widget-factory. Same problem there, cannot copy text from gtk3-widget-factory to xterm when they are in different screens. Other way works ok, same with firefox. Same problem with gedit also. Gedit uses gtk3 in fedora 22. Between firefox and gedit both "PRIMARY" and "CLIPBOARD" copying works ok.

So this seems to be general gtk3 problem with multiple screens.
(Reporter)

Comment 3

2 years ago
This migth be fedora 22 only bug that is fixed in upstream and 23:
http://ftp.gnome.org/pub/gnome/sources/gtk+/3.17/gtk+-3.17.6.changes
https://bugzilla.gnome.org/show_bug.cgi?id=721398
https://bodhi.fedoraproject.org/updates/gtk3-3.17.6-1.fc23
(Reporter)

Comment 4

2 years ago
I upgraded fc22 -> fc23 and bug goes away. So this is gtk3 bug, not mozilla bug.

Marking as resolved invalid.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.