widget/gtk/WidgetStyleCache.cpp:191:29: error: 'PodArrayZero' was not declared in this scope (--disable-dbus)

RESOLVED FIXED in Firefox 48

Status

()

Core
Widget: Gtk
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: Jan Beich, Unassigned)

Tracking

({regression})

Trunk
mozilla49
Unspecified
FreeBSD
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox48 fixed, firefox49 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
In file included from widget/gtk/Unified_cpp_widget_gtk0.cpp:29:
widget/gtk/WidgetStyleCache.cpp:191:3: error: use of undeclared identifier
      'PodArrayZero'; did you mean 'mozilla::PodArrayZero'?
  PodArrayZero(sStyleStorage);
  ^~~~~~~~~~~~
  mozilla::PodArrayZero
dist/include/mozilla/PodOperations.h:65:1: note: 'mozilla::PodArrayZero'
      declared here
PodArrayZero(T (&aT)[N])
^
In file included from widget/gtk/Unified_cpp_widget_gtk0.cpp:29:
widget/gtk/WidgetStyleCache.cpp:198:3: error: use of undeclared identifier
      'PodArrayZero'; did you mean 'mozilla::PodArrayZero'?
  PodArrayZero(sWidgetStorage);
  ^~~~~~~~~~~~
  mozilla::PodArrayZero
dist/include/mozilla/PodOperations.h:65:1: note: 'mozilla::PodArrayZero'
      declared here
PodArrayZero(T (&aT)[N])
^
2 errors generated.
Comment hidden (obsolete)
(Reporter)

Comment 2

2 years ago
In file included from widget/gtk/Unified_cpp_widget_gtk1.cpp:128:
In file included from widget/gtk/nsWidgetFactory.cpp:34:
widget/gtk/WakeLockListener.h:17:10: fatal error: 'mozilla/ipc/DBusConnectionRefPtr.h'
      file not found
#include "mozilla/ipc/DBusConnectionRefPtr.h"
         ^
1 error
(Reporter)

Updated

2 years ago
Blocks: 1266054
(Reporter)

Comment 4

2 years ago
Created attachment 8750562 [details] [diff] [review]
comment 0 fix

Apologies for mixing two separate issues but they're a bit hard to untangle due to namespace pollution caused by unified build.
Attachment #8750562 - Flags: review?(karlt)
(Reporter)

Comment 5

2 years ago
Created attachment 8750563 [details] [diff] [review]
comment 2 fix
Attachment #8750563 - Flags: review?(karlt)
Comment on attachment 8750562 [details] [diff] [review]
comment 0 fix

Thanks!
Attachment #8750562 - Flags: review?(karlt) → review+
Attachment #8750563 - Flags: review?(karlt) → review+
(In reply to Jan Beich from comment #5)
> Created attachment 8750563 [details] [diff] [review]
> comment 2 fix

Thanks for fixing this issue.
(Reporter)

Updated

2 years ago
Keywords: checkin-needed

Comment 9

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/639d6b288e9b
https://hg.mozilla.org/mozilla-central/rev/ac974fdf2755
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox49: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
(Reporter)

Updated

2 years ago
Keywords: regression
(Reporter)

Comment 10

2 years ago
Comment on attachment 8750562 [details] [diff] [review]
comment 0 fix

Chasing https://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?changeset=cb42beedc07e

Approval Request Comment
[Feature/regressing bug #]: bug 1234158 regression
[User impact if declined]: --disable-dbus build broken
[Describe test coverage new/current, TreeHerder]: m-c
[Risks and why]: Low, can only break build on Linux
[String/UUID change made/needed]: None
Attachment #8750562 - Flags: approval-mozilla-aurora?
status-firefox48: --- → affected
Comment on attachment 8750562 [details] [diff] [review]
comment 0 fix

Fix the build with some options, tiny risk, taking it.
Attachment #8750562 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Reporter)

Comment 12

2 years ago
Only comment 0 fix (the approved patch), comment 2 fix dependency (bug 1266054) wasn't backported/nominated for Aurora48 yet.
Flags: needinfo?(jbeich)
https://hg.mozilla.org/releases/mozilla-aurora/rev/94c2c4e54006
I'm setting status48 to 'fixed', but this will make it difficult for us to see if/when the comment2fix patch is ready to be uplifted. If/when you request uplift for it, please try to remember to set status48 back to 'affected' to make it easier to see this in our uplift queries. :)
status-firefox48: affected → fixed
Flags: needinfo?(jbeich)
jan, so does comment 0 or comment 2 fix (or both need to be uplifted ?)
Flags: needinfo?(jbeich)
(Reporter)

Comment 15

a year ago
Bug 1266054 wasn't backported to FF48, so there was no need to backport comment 2 fix as well.
Flags: needinfo?(jbeich)
You need to log in before you can comment on or make changes to this bug.