keyboard shortcut to file mail into subfolders

RESOLVED FIXED

Status

SeaMonkey
MailNews: Message Display
--
enhancement
RESOLVED FIXED
16 years ago
8 years ago

People

(Reporter: Tarjei Huse, Unassigned)

Tracking

({helpwanted})

Trunk
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: See comment 10)

(Reporter)

Description

16 years ago
It is quite anoying to see how badly mozilla helps us people who try not to get
carpal tunneling syndrome. Please,please,please provide more keys to the
mailclient, at least:
CTRL-Enter (I saw that the linux version (debian)  had it. -> send message
DELETE or CTRL-Delete -> delete message 

and (very important):
Some quick (so lusers can remember it) hotkey to file emails into subfolders.

Thank you!

Comment 1

16 years ago
Ctrl enter to send the message on Windows is bug 50255. 
confirming rfe.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
QA Contact: sheelar → olgam
Summary: Far to few functionkeys in mozilla → Far too few functionkeys in mozilla

Comment 3

16 years ago
It is wonderful to read about such an enhancement. We all need shortcuts, but do
you use all what exists? I try to use many, but probably not all. 
For Delete - we have Delete key in the middle of navigation pane. 
For Send - Ctrl+Enter - it works now on Linux, Mac, and couple last builds on
Windows. 
About filing emails into subfolders: I use access keys here - Alt+M, M/C (to
select Move/Copy from Messages menu). Then use arrow keys to navigate to the
account, Enter to select it, then arrow key to navigate to the proper folder.
-->varada
Assignee: ducarroz → varada

Comment 5

15 years ago
ctrl-enter exists, delete should exist, i'm selecting what appears to be the 
only remaining request..
Summary: Far too few functionkeys in mozilla → hotkey to file mail into subfolders

Comment 6

15 years ago
*** Bug 151849 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
see also bug 21211
Assignee: varada → nobody
Component: Composition → Mail Window Front End
Keywords: helpwanted
OS: Windows 2000 → All
QA Contact: olgam → lchiang
Hardware: PC → All
Summary: hotkey to file mail into subfolders → keyboard shortcut to file mail into subfolders
Target Milestone: --- → Future

Comment 8

15 years ago
correcting what was changed.
Assignee: nobody → varada
QA Contact: lchiang → olgam
Target Milestone: Future → ---
taking all of varada's bugs.
Assignee: varada → sspitzer
Ctrl+Enter is bug 50255.
Filing message to folder on keypress is bug 21211.

This bug is about Ctrl+Delete.

Please change the summary. Or resolve this bug and open a new one on Ctrl+Delete.
Whiteboard: See comment 10

Comment 11

13 years ago
What exactly should Ctrl+Del do? I can already delete the selected message by
pressing Del. This works in the 3-pane and in the stand-alone message window.

So was this issue already fixed in the meantime in another bug? Or do I
misunderstand this bug report?
Product: Browser → Seamonkey

Updated

12 years ago
Assignee: sspitzer → mail
Assignee: mail → nobody
QA Contact: olgam → message-display

Comment 12

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
(Reporter)

Comment 13

8 years ago
It is fun to come back to a bug filed in 2002 and see how much has changed :)

I still wish for a way to quickly move mails to subfolders, but I think the UI probably should be hashed out in an extension before getting moved into the mainline so I mark this bug as resolved - the two other complaints have been fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.