Add process manager tool to developer tool.

RESOLVED DUPLICATE of bug 1255843

Status

--
enhancement
RESOLVED DUPLICATE of bug 1255843
3 years ago
4 months ago

People

(Reporter: mtseng, Assigned: mtseng)

Tracking

(Blocks: 2 bugs)

unspecified
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

With e10s or future added out-of-process compositor, we create more and more process within firefox. It might be better to have a tool that can inspect the process that we created and query the process stat. We can reference the Task Manager in chrome.
tracking-e10s: --- → ?

Updated

3 years ago
Blocks: 875871
tracking-e10s: ? → +
Do you mean something like bug 400120 or bug 515352 here, or is this a different idea?
Flags: needinfo?(mtseng)
bug 400120 or bug 515352 is per tab basis. This bug is per process basis. So I think this is different idea.
Flags: needinfo?(mtseng)
Severity: normal → enhancement
There is also bug 1255843 about per-process memory stats.  Is that what you are looking for?  If not, what process stats did you have in mind?
Flags: needinfo?(mtseng)
Ah, that what I'm looking for. Thanks for the info!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(mtseng)
Resolution: --- → DUPLICATE
Duplicate of bug: 1255843

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.