Telemetry is apparently not threadsafe.

RESOLVED FIXED in Firefox 52

Status

()

Core
DOM: Workers
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: KWierso, Assigned: baku)

Tracking

unspecified
mozilla52
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox52 fixed)

Details

(Whiteboard: btpp-active)

Attachments

(1 attachment)

Comment hidden (empty)
(Reporter)

Comment 2

2 years ago
Landed https://hg.mozilla.org/integration/mozilla-inbound/rev/a3a8e4f9cd21 to hopefully stop it from asserting until a better fix can land.
Keywords: leave-open
(Assignee)

Comment 4

2 years ago
Is this a duplicate of bug 1258183 ?
Flags: needinfo?(jseward)
(In reply to Andrea Marchesini (:baku) from comment #4)
> Is this a duplicate of bug 1258183 ?

Yes, I think it is.  Bug 1258183 may not entirely de-race Telemetry, but it is a
good start.  There may be followups depending on whether any remaining Telemetry
races are observed with TSan after bug 1258183 lands.
Flags: needinfo?(jseward)
Whiteboard: btpp-active
Depends on: 1258183
(Assignee)

Comment 7

2 years ago
Created attachment 8804203 [details] [diff] [review]
telemetry.patch

It seems that all the dependences are now resolved.
I would like to enable this telemetry ID in runnables.
Attachment #8804203 - Flags: review?(bkelly)
Attachment #8804203 - Flags: review?(bkelly) → review+

Comment 8

2 years ago
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5a794352cf9c
Add telemetry for sync worker runnables, r=bkelly
(Assignee)

Updated

2 years ago
Keywords: leave-open

Comment 9

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/5a794352cf9c
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox52: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
You need to log in before you can comment on or make changes to this bug.