webrtc: add NetBSD video support

RESOLVED DUPLICATE of bug 826985

Status

()

Core
WebRTC: Audio/Video
P4
normal
Rank:
45
RESOLVED DUPLICATE of bug 826985
2 years ago
2 years ago

People

(Reporter: Thomas Klausner, Unassigned)

Tracking

Trunk
All
NetBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160502172042

Steps to reproduce:

NetBSD has support for Linux' v4l2 API. pkgsrc carries a patch that adds some compatibility/options for it, I've applied it to trunk.
(Reporter)

Comment 1

2 years ago
Created attachment 8751683 [details] [diff] [review]
NetBSD-webrtc.diff

Patch from pkgsrc applied to trunk.
Attachment #8751683 - Flags: review?(rjesup)
(Reporter)

Updated

2 years ago
OS: Unspecified → NetBSD
Hardware: Unspecified → All

Updated

2 years ago
Component: Untriaged → WebRTC: Audio/Video
Product: Firefox → Core
Whiteboard: [review? on jesup]
Comment on attachment 8751683 [details] [diff] [review]
NetBSD-webrtc.diff

Review of attachment 8751683 [details] [diff] [review]:
-----------------------------------------------------------------

See bug 826985, which includes most of this.  Likely this should be dupped to that bug, and if there's anything here missing there, added to that one.

::: old-configure.in
@@ +3638,5 @@
>      MOZ_RAW=1
>      MOZ_VPX_ERROR_CONCEALMENT=1
>  
> +    dnl with libv4l2 we can support more cameras
> +    PKG_CHECK_MODULES(MOZ_LIBV4L2, libv4l2)

Almost all library dependencies have --enable/disable controls in old-configure.in

Also: this tells you if the current system has the library, but that could be bad for packaging builds (admittedly, something the BSDs generally avoid).  With --enable/disable, one can control if the dependency is baked in or not, but as in bug 826985, a dynamic load/dlsym gets you a much better packaged experience (and maybe even for local builds if something changes).
Attachment #8751683 - Flags: review?(rjesup) → review-

Updated

2 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
See Also: → bug 826985
Whiteboard: [review? on jesup]

Updated

2 years ago
Rank: 45
Priority: -- → P4
(Reporter)

Comment 3

2 years ago
I compared my diff against the latest one in Bug 826985, and that one is a strict superset (except for old-configure.in which is handled better there). I'll close this bug now.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 826985

Updated

2 years ago
See Also: bug 826985
You need to log in before you can comment on or make changes to this bug.