bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Keyboard copy (ctrl + x) in gdocs spreadsheet not working

RESOLVED INVALID

Status

()

Core
Keyboard: Navigation
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: kar, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: btpp-followup-2016-05-27)

(Reporter)

Description

2 years ago
I apologize if this isn't the right bugzilla component - it was a guess on my part.

I'm on Nightly, 49.0a1 (2016-05-12), on a Windows 10 machine on a Lenovo Carbon X1 Touch.

I've been trying to copy and paste a graph I made from GDocs on one tab into another. It's not recognizing the 'copy' (ctrl + x), as nothing gets pasted.

However, if I open up the gdocs spreadsheet in chrome and copy it (ctrl + x), I can paste it into the other gdocs doc that's in firefox.
Any chance you can share the documents, Karen?
Flags: needinfo?(krudnitski)
(Just sharing with *@mozilla.com may be enough to diagnose the problem)

Comment 4

2 years ago
(In reply to Karen Rudnitski [:kar] from comment #3)
> Trying to copy from here:
> https://docs.google.com/spreadsheets/d/1vivp_kvDy84Dh0QUTminrRhVLYybhgegqG-
> MKXWKIyQ/edit#gid=121864854 
> 
> to here:
> https://docs.google.com/document/d/
> 1Pyzek4XlcwkNqiBivMSDCRFp1wZ1EsmWigfpvBsYmvM/edit#heading=h.ukqrrqqh86i5

I made my own google doc, and tried to copy one of the graphs in the first tab into that doc (using chrome). Maybe I'm doing it wrong but it doesn't seem to work on chrome either :S (mac OS X). I'll take another look at trying it out, but I'm having trouble copying graphs at all.
Whiteboard: btpp-followup-2016-05-27
I confirm that it's not working in Chrome for me either. So Google has simply not implemented copying of graphs to the clipboard yet - in any browser. We're working on improving the copy/cut/paste functionality to make it a lot easier to support this kind of stuff - see https://github.com/garykac/clipboard/blob/master/clipboard.md

Once Google implements this, depending on how exactly they choose to do it, this might become a duplicate of bug 1234024 as Mike mentions, or bug 891247, or bug 1221562, or a dupe of yet-to-be-filed follow-up bugs for the latter... Right now I'll close it, but I fully expect to have to re-open it at some point. #-/
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(hsteen)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.