Closed Bug 1272556 Opened 6 years ago Closed 6 years ago

Access denied for URL blob moz-extension in web extensions

Categories

(Firefox :: Extension Compatibility, defect)

48 Branch
x86_64
Windows 10
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1271345

People

(Reporter: mail, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.102 Safari/537.36

Steps to reproduce:

I'm trying to run my chromium extension in firefox 48 (and you have good progress since previous versions). Here is the code:

var blob = new Blob(['text'], {
    type: 'text/plain'
});
var url = URL.createObjectURL(blob);
chrome.downloads.download({
    url: url
});



Actual results:

An error appeared: "Error: Type error for parameter options (Error processing url: Error: Access denied for URL blob:moz-extension://1d3b89b0-e3f7-4ff7-bac6-25dc80acd6c4/837a0080-bfb9-4348-8165-76819a07cc65) for downloads.download."

Stack:
makeError() Schemas.jsm:167
throwError() Schemas.jsm:936
checkParameters/fixedArgs<() Schemas.jsm:999
map() self-hosted
checkParameters() Schemas.jsm:992
inject/stub() Schemas.jsm:1028
<anonymous> background.js:6 <- this is my script



Expected results:

Extension should download the file created by Blob.
Also here is a sample of firefox extension which reproduces the bug: https://github.com/egoroof/sample-chrome-extension/tree/firefox
Component: Untriaged → Extension Compatibility
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1271345
You need to log in before you can comment on or make changes to this bug.